Bug 1822924 - etcd backup script request snapshot backup from a single endpoint not multiple
Summary: etcd backup script request snapshot backup from a single endpoint not multiple
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Suresh Kolichala
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-10 14:05 UTC by Suresh Kolichala
Modified: 2020-07-13 17:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The backup script was invoked with all ETCD endpoints. Consequence: This was overlooked in etcd 3.3.x versions, but in etcd 3.4.x, this invocation results in failure. Fix: Set the ETCDCTL_ENDPOINTS to a single member. Result: backups are successfully taken.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:26:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 304 0 None closed Bug 1822924: The snapshot backup must be requested from a single endpoint not multiple 2020-06-23 09:56:43 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:27:13 UTC

Description Suresh Kolichala 2020-04-10 14:05:27 UTC
Description of problem:
By default, etcdctl is invoked with ETCDCTL_ENDPOINTS set to all etcd members. However, when invoking snapshot backup, it should be invoked with a single endpoint. This is strictly enforced in the new etcd versions of 3.4.x.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login to one of the master hosts
2. Attempt to take a backup by invoking cluster-backup.sh

Actual results:
In 4.5, where etcd is bumped to use 3.4.7, it fails with an error:
Error: snapshot must be requested to one selected node, not multiple [https://10.0.145.58:2379 https://10.0.134.79:2379 https://10.0.137.186:2379 https://10.0.5.140:2379]

Expected results:
snapshot db and kube resources are successfully saved to backup directory specified.

Additional info:

Comment 7 errata-xmlrpc 2020-07-13 17:26:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.