Bug 1823005 - earlyoom is not being pulled in when upgrading F30/F31 to F32
Summary: earlyoom is not being pulled in when upgrading F30/F31 to F32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: earlyoom
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vitaly Zaitsev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F32FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-04-10 21:55 UTC by Chris Murphy
Modified: 2020-04-15 00:13 UTC (History)
4 users (show)

Fixed In Version: earlyoom-1.6-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-13 21:29:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Chris Murphy 2020-04-10 21:55:48 UTC
Description of problem:

Applies only to Fedora Workstation

earlyoom is not being pulled in when upgrading F30/F31 to F32, but should be. It is in clean installs but not upgrades (either dnf system-upgrade or Software). There's been some difficulty figuring out how to get it pulled in on upgrades. Current idea is a workaround by adding a weak dependency: supplements fedora-release-workstation
https://pagure.io/fedora-workstation/issue/138

This is an approved feature for F32 including upgraded systems.
https://fedoraproject.org/wiki/Changes/EnableEarlyoom



Version-Release number of selected component (if applicable):
earlyoom-1.5-1.fc32.x86_64
fedora-release-workstation-32-0.8.noarch


How reproducible:

Always


Steps to Reproduce:
1. Upgrade f30/f31 to f32
2.
3.

Actual results:

No earlyoom package present

Expected results:

earlyoom package should be installed and running


Additional info:


If FE is not approved then upgraded systems will not have earlyoom, and will differ in behavior from clean f32 systems when in low memory situations.

Comment 1 Fedora Blocker Bugs Application 2020-04-10 21:58:20 UTC
Proposed as a Freeze Exception for 32-final by Fedora user chrismurphy using the blocker tracking app because:

 Having parity between clean and upgraded systems for this approved feature is desired.

Comment 2 Fedora Update System 2020-04-11 10:04:18 UTC
FEDORA-2020-c7428d5021 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c7428d5021

Comment 3 Fedora Update System 2020-04-11 18:51:55 UTC
FEDORA-2020-c7428d5021 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-c7428d5021`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c7428d5021

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 František Zatloukal 2020-04-13 15:39:01 UTC
FEDORA-2020-c7428d5021 fixes the issue. (Update is somehow stuck in pending, not testing yet it seems, I've tested it by putting it in my repo).

Comment 5 Geoffrey Marr 2020-04-13 19:43:24 UTC
Discussed during the 2020-04-13 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-04-13/f32-blocker-review.2020-04-13-16.04.txt

Comment 6 Fedora Update System 2020-04-13 21:29:07 UTC
FEDORA-2020-8aa446a1ce has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Chris Murphy 2020-04-15 00:13:57 UTC
Tested F31->F32 dnf system-upgrade and earlyoom is being pulled in, and after upgrade it's installed and running. Yay!


Note You need to log in before you can comment on or make changes to this bug.