Bug 182301 - Anaconda crashes after setting root password
Anaconda crashes after setting root password
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-21 13:11 EST by Thilo Pfennig
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 14:03:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda dump file created after exception (71.55 KB, text/plain)
2006-02-24 10:49 EST, Thomas Feeney
no flags Details

  None (edit)
Description Thilo Pfennig 2006-02-21 13:11:21 EST
Description of problem:

I have made a custom install. i wanted to delete a SuSE reiserfs partition on my
second hard drive and install fc5test3 on this. As I do not have DHCP in my
network I also added the network data by hand. After I typed in the root
password twice Anaconda reported an error. I could go to Debug. As I do not know
how to save the traceback I can not provide it right now. If someboy gives me
instructions how to save traceback from install, i could provide more details.


Version-Release number of selected component (if applicable):


How reproducible:

every time

Additional info:

I also have an old FC4 stable release on hard disk that i did not want to overwrite.
Comment 1 Thomas Feeney 2006-02-22 16:04:14 EST
I tried both FC5 test2-AMD64 and FC5 test3-x86 (32bit) on Sun Ultra 20.  Both
crash during install shortly after root password and disk partitioning windows
of graphic install.  Boot loader install was not chosen.  I couldn't save debug
info to floppy because my machine doesn't have one.  
Hardware info:
Sun Ultra 20, 2.2Gig AMD64 Athlon
Nvidia NVS 280 graphics card (recognized as Quadro Fx 330)
Philips 230W monitor (recognized)

NOTE:  FC4 32bit runs great on this machine. Under FC4, the graphics driver
automatically chosen is VGA driver (generic).
Comment 2 Jeremy Katz 2006-02-22 16:13:47 EST
One of the options right there on the screen is to save the traceback. 
Alternately, if you switch to tty2, it's saved as /tmp/anacdump.txt
Comment 3 Thomas Feeney 2006-02-23 09:03:23 EST
(In reply to comment #2)
> One of the options right there on the screen is to save the traceback. 
> Alternately, if you switch to tty2, it's saved as /tmp/anacdump.txt

Right there on the screen are three options: Save-to-floppy, Debug, and OK. As I
said, I don't have a floppy.  I'll try switching to tty2 (I assume with the Alt-Fx 
key combination?) and try to save it, although it doesn't make sense to me since
 /tmp doesn't exist if I'm in the middle of an install (it crashes immediately
after root password screen).  I'm thinking that the video driver probed by
Anaconda might be the problem.  If there is a way to continue using the generic
VGA driver for the rest of the install, perhaps that would solve it.
Comment 4 Thomas Feeney 2006-02-24 10:49:46 EST
Created attachment 125185 [details]
anaconda dump file created after exception
Comment 5 Jeremy Katz 2006-02-24 11:48:04 EST
It looks like there was an error reading your media.

For FC5 final, we definitely need to be wrapping this one like we do reading
packages with retries so that we at least catch this instead of just tracebacking.
Comment 6 Thomas Feeney 2006-02-24 13:00:42 EST
I got the same exception when installing the AMD64bit version from a DVD, from
installing the 32bit x86 version from a CD-RW, and from installing the 32bit x86
version from a CD-R.  Here's what I'll try next:  I'll download the disk1 32bit
x86 iso image again, burn it to a CD-R, and try again.
Comment 7 Thomas Feeney 2006-02-24 13:58:39 EST
The sha1sum value of disk1 did not match SHA1SUM file value.  I downloaded
another iso image of disk 1, checked the sha1sum, and then SUCCESSFULLY
installed FC5 test3.  I recommend closing this bug.
Comment 8 David Cantrell 2006-02-24 14:03:37 EST
We concur.
Comment 9 Thilo Pfennig 2006-02-25 03:28:35 EST
4 of 5 of my ISOs also had a bad checksum. I never had that before.

Thilo

Note You need to log in before you can comment on or make changes to this bug.