Bug 1823011 - It's not possible to configure network devices in TUI
Summary: It's not possible to configure network devices in TUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F32FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-04-10 22:26 UTC by Jan Stodola
Modified: 2020-04-27 08:19 UTC (History)
14 users (show)

Fixed In Version: anaconda-32.24.6-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-16 01:41:40 UTC
Type: Bug


Attachments (Terms of Use)
anaconda.log (10.91 KB, text/plain)
2020-04-10 22:28 UTC, Jan Stodola
no flags Details
syslog (653.37 KB, text/plain)
2020-04-10 22:29 UTC, Jan Stodola
no flags Details

Description Jan Stodola 2020-04-10 22:26:11 UTC
Description of problem:
When running anaconda in text mode, it's not possible to configure network devices. The only option in "Network configuration" is "Set host name":


Installation

1) [x] Language settings                 2) [x] Time settings
       (English (United States))                (America/New_York timezone)
3) [!] Installation source               4) [!] Software selection
       (Processing...)                          (Processing...)
5) [!] Installation Destination          6) [x] Network configuration
       (Processing...)                          (Connected: enp8s0, enp7s0,
                                                enp1s0)
7) [x] Root password                     8) [!] User creation
       (Root account is disabled.)              (No user will be created)

Please make a selection from the above ['b' to begin installation, 'h' to help,
'q' to quit, 'r' to refresh]: 6
================================================================================
================================================================================
Network configuration


Host Name: localhost.localdomain


Current host name: localhost


1) Set host name

Please make a selection from the above ['c' to continue, 'h' to help, 'q' to
quit, 'r' to refresh]:
Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Run installation in text mode (use "text" on the kernel command line)
2. Enter the "Network configuration" spoke
3. Try to configure network devices

Actual results:
No option to configure network devices.

Expected results:
It's possible to edit network devices in text mode.

Comment 1 Jan Stodola 2020-04-10 22:28:48 UTC
Created attachment 1677917 [details]
anaconda.log

Comment 2 Jan Stodola 2020-04-10 22:29:31 UTC
Created attachment 1677918 [details]
syslog

Version-Release number of selected component (if applicable):
anaconda-33.9-1.fc33

Comment 3 Radek Vykydal 2020-04-14 12:58:31 UTC
https://github.com/rhinstaller/anaconda/pull/2440

Comment 4 Radek Vykydal 2020-04-14 12:59:16 UTC
It is reproducible also on latest F32.

Comment 5 Fedora Blocker Bugs Application 2020-04-14 13:32:03 UTC
Proposed as a Freeze Exception for 32-final by Fedora user rvykydal using the blocker tracking app because:

 It is impossible to configure a network device in text mode.
The fix is easy and isolated.

Comment 6 Fedora Blocker Bugs Application 2020-04-14 16:14:09 UTC
Proposed as a Blocker for 32-final by Fedora user sgallagh using the blocker tracking app because:

 "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces." (basic release criteria) plus "The installer must be able to use all supported local and remote package and installer sources." (Final criteria)

I'd argue that if you cannot configure the network for anything other than default operation (DHCP auto-detection) in text mode, it's not meeting these criteria.

Comment 7 Adam Williamson 2020-04-14 16:14:37 UTC
Definitely +1 FE, but really, I might be +1 blocker on this? It seems like a big problem...

Comment 8 Adam Williamson 2020-04-14 16:14:51 UTC
...yeah, what sgallagh said. :)

Comment 9 Stephen Gallagher 2020-04-14 16:15:31 UTC
So, I'm +1 blocker here, with +1 FE if others disagree with calling it a blocker.

Comment 10 Ben Cotton 2020-04-14 16:57:05 UTC
+1 blocker, +1 FE if blocker is rejected

Comment 11 Fedora Update System 2020-04-14 17:06:50 UTC
FEDORA-2020-0ef5c91a97 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-0ef5c91a97

Comment 12 Adam Williamson 2020-04-14 17:09:06 UTC
So we're actually +3 blocker here. Accepting.

Comment 13 Kamil Páral 2020-04-15 13:33:46 UTC
With F32 RC1.3, I can configure network devices. I haven't really tried to configure them, but the options are there.

Comment 14 Lukas Ruzicka 2020-04-15 13:57:51 UTC
With F32 RC1.3, the option is there, however on my T460s (which uses a normal and a wifi card) I can only configure the normal ethernet (en.. something) and the other card, usually seen as wl... something, is not visible and thus cannot be configured. 
In the graphical anaconda, I can normally manipulate both of that cards.

Comment 15 Radek Vykydal 2020-04-15 14:29:23 UTC
In text mode only configuration of wired network devices is supported.

Comment 16 Fedora Update System 2020-04-16 01:41:40 UTC
FEDORA-2020-0ef5c91a97 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Lukas Ruzicka 2020-04-16 11:14:08 UTC
(In reply to Radek Vykydal from comment #15)
> In text mode only configuration of wired network devices is supported.

I will notice that, but can you explain why?

Comment 18 Radek Vykydal 2020-04-27 08:19:00 UTC
We've always been trying to use existing UIs to configure networking in Anaconda. In GUI we are using NetworkManager connection editor. For TUI we don't have similar tool that would be easy to integrate. Using terminal and nmcli seems like a better option than trying to create our own UI, a good enough solution for the (rather rare ?) cases when more advanced configuration is required - we haven't been actually seeing much requests to extend the UI for network configuration in text mode. We don't expect to bring TUI to par with GUI regarding configuration of network devices but maybe wireless would be something to consider - if we had user requests.


Note You need to log in before you can comment on or make changes to this bug.