Bug 182303 - RFE: add 256 color terminal support to vte/gnome-terminal
RFE: add 256 color terminal support to vte/gnome-terminal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks: FC5Update
  Show dependency treegraph
 
Reported: 2006-02-21 13:22 EST by dann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 13:57:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dann 2006-02-21 13:22:09 EST
It would be nice if vte/gnome-terminal supported 256 colors by default in FC5.
xterm is already compiled with 256 color support by default.
Being able to use 256 color terminals is a major improvement for terminal users.

I wrote a patch that will be applied to vte to add support for 256 colors, but
it will only be applied after branching for gnome-2.14. It would be nice if FC5
had this support, rather than wait for FC6. See:
http://bugzilla.gnome.org/show_bug.cgi?id=168251
Comment 1 Matthias Clasen 2006-02-21 13:46:51 EST
Closing, since we normally track enhancement requests upstream.
Comment 2 dann 2006-02-21 14:08:34 EST
I am reopening this because it seems that given what you said in comment #1 you
might have misunderstood the reason for this RFE. 

Here is the reasoning:

FC5 will ship with gnome-2.14
vte/gnome-terminal in gnome-2.14 will NOT have support for 256 color terminal
A patch exists to provide such support. So the point of this RFE is to add the 
256 colors support to FC5 DESPITE gnome-2.14 not including such support.
Comment 3 Ray Strode [halfline] 2006-02-22 21:13:00 EST
Hi,

As of test3 we are trying to keep feature enhancements to a minimum.  For the
most part we are only looking at blocker bugs at this point.  We might be able
to get this in to fc5 as an update after fc5 is released however.
Comment 4 Ray Strode [halfline] 2006-03-24 17:00:40 EST
So when this lands upstream, will throw it into rawhide and updates-testing. 
After it's baked there for a while, we'll consider doing an FC5 Update.
Comment 5 dann 2006-04-06 02:57:15 EDT
(In reply to comment #4)
> So when this lands upstream, will throw it into rawhide and updates-testing. 
> After it's baked there for a while, we'll consider doing an FC5 Update.

The patch has landed upstream now...
Comment 6 Matthias Clasen 2006-08-02 13:57:58 EDT
fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.