Bug 182310 - hd Partitions reordered
hd Partitions reordered
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 13:55 EST by Darwin H. Webb
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 16:12:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2006-02-21 13:55:47 EST
Description of problem:
created hda1 as ext3 /boot
created hda2 as swap 
created PV for LVM

Partitions were rearranged as
hda2 - lvm
hda3 - swap

I had orginally deleted all partitons.
created hda1
create hda 2 as LVM
create hda3 as swap but thoht I had deleted the LVM as I wanted the swap outside
the lvm for Live CD usage.
From there on, I could not get the hda2 to be a swap as lvm pv would change it
to hda3.

Seems to be a partiton table reload is needed in more than one place?

Version-Release number of selected component (if applicable):
FC5T3 install CD #1

How reproducible:
Don't know, it was dependenet on how partitions were set up and rearranged.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Had to settle for swap inside PV vg

Expected results:
partition to stay as defined hda2 swap and hdan to follow.

Additional info:

Other clean up notes: 
1. VolumeGroup name is still short -12-15 chars, need 32 or more.
2. do not supply a default VolGruop00 name in the list.
It is easy to forget to change it and then it has to be re done.
add warning message like the invalid characters message, say, VolGroup name is
missing and give exapmle as VolGroup00

Darwin
Comment 1 Jeremy Katz 2006-02-22 16:12:58 EST
The ordering is based on size to allow growing partitions to fill the disk
Comment 2 Darwin H. Webb 2006-02-23 10:25:59 EST
I think you miss understood the problem.

I was trying to make hda2 a regular swap and hda3 an LVM
Two seperate partitions.
The LVM on hda3 would be more growable than having a swap file partiton in the
middle.
It is not the swap file inside an LVM at the end like the default but seperate

hda2 - swap - existing
hda3 - pv/vg creating, done, ok

partitons changed to 
hda2 - pv/vg
hda3 - swap

I have no problem doing this in 2 other distros.
If I install test 3 again I'll try to reproduce it.

Darwin

Note You need to log in before you can comment on or make changes to this bug.