Bug 1823252 - spaces are needed for the error message when selected namespace does not support installation mode
Summary: spaces are needed for the error message when selected namespace does not supp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-13 03:22 UTC by Yadan Pei
Modified: 2020-07-13 17:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Missing space before and after installMode type in the console alert Consequence: Alert message has wrong format Fix: Add space before and after installMode type in the console alert Result: Alert message has right format
Clone Of:
Environment:
Last Closed: 2020-07-13 17:26:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5030 0 None closed Bug 1823252: spaces are needed for the error message when selected namespace does not support installation mode 2020-10-01 07:06:54 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:27:13 UTC

Description Yadan Pei 2020-04-13 03:22:40 UTC
Description of problem:
In operator subscription modal, when user selects a namespace that does not support installation mode, console will show error message(below), we need add spaces for the message:

Namespace does not support installation mode
The operator group in the openshift-operators namespace does not support thesingle namespaceinstallation mode.

Version-Release number of selected component (if applicable):
    4.5.0-0.nightly-2020-04-12-180647

How reproducible:
Always

Steps to Reproduce:
1. admin user goes to Operators -> OperatorHub -> select 'Crunchy PostgreSQL for OpenShift' -> click 'Install' button -> Change 'Installed Namespace' to openshift-operators


Actual results:
1. Console will show message:
Namespace does not support installation mode
The operator group in the openshift-operators namespace does not support thesingle namespaceinstallation mode.

Expected results:
1. The message is correct, but we need two more space between the words 'the' and installmode which will be much clear:
Namespace does not support installation mode
The operator group in the openshift-operators namespace does not support the single namespace installation mode

Additional info:

Comment 3 Yadan Pei 2020-04-16 01:54:36 UTC
Now the error message is:
The operator group in the openshift-operators namespace does not support the single namespace installation mode.


Verified on     4.5.0-0.nightly-2020-04-15-194358

Comment 4 errata-xmlrpc 2020-07-13 17:26:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.