Bug 1823253 - The filters makes catalog list page broken
Summary: The filters makes catalog list page broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.5.0
Assignee: Bipul Adhikari
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-13 03:56 UTC by shahan
Modified: 2020-07-13 17:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:26:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5022 0 None closed Bug 1823253: Fix Textfilter issue in Filter Toolbar 2020-06-23 09:56:51 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:27:13 UTC

Description shahan 2020-04-13 03:56:23 UTC
Description of problem:
The filters makes catalog list page broken

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-12-180647

How reproducible:
Always

Steps to Reproduce:
1. goto k8s/cluster/config.openshift.io~v1~OperatorHub/cluster/sources
2. input names in the filter textbox
3.

Actual results:
page got "Oh no! Something went wrong":
TypeError
Description:
Cannot read property 'name' of undefined

Component Trace:
in w
    in T
    in div
    in div
    in div
    in ListPageWrapper_
    in Unknown
    in Unknown
    in w
    in x
    in w
    in div
    in w
    in w
    in w
    in MultiListPage
    in H
    in component
    in t
    in t
    in div
    in Data
    in StatusBox
    in div
    in Unknown
    in Unknown
    in Unknown
    in Unknown
    in w
    in x
    in w
    in Unknown
    in o
    in DetailsPage
    in l
    in c
    in Unknown
    in w
    in t
    in t
    in div
    in div
    in section
    in d
    in Unknown
    in w
    in w
    in div
    in f
    in div
    in f
    in NotificationDrawer
    in Unknown
    in w
    in Unknown
    in Unknown
    in w
    in x
    in w
    in main
    in div
    in y
    in component
    in t
    in t
    in t
Stack Trace:
TypeError: Cannot read property 'name' of undefined
    at name (https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/main-chunk-87af597169cac6453711.min.js:1:379506)
    at https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/main-chunk-87af597169cac6453711.min.js:1:832666
    at t.a (https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/vendors~main-chunk-887c6bd92cd9c6056a4d.min.js:18:9275)
    at Object.t.a (https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/vendors~main-chunk-887c6bd92cd9c6056a4d.min.js:12:131776)
    at https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/main-chunk-87af597169cac6453711.min.js:1:832659
    at https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/vendors~main-chunk-887c6bd92cd9c6056a4d.min.js:47:3111
    at t.a (https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/vendors~main-chunk-887c6bd92cd9c6056a4d.min.js:18:37468)
    at https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/vendors~main-chunk-887c6bd92cd9c6056a4d.min.js:47:2876
    at Object.t.a (https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/vendors~main-chunk-887c6bd92cd9c6056a4d.min.js:12:83312)
    at https://console-openshift-console.apps.juzhao-45.qe.devcluster.openshift.com/static/main-chunk-87af597169cac645371

Expected results:


Additional info:

Comment 4 shahan 2020-05-06 08:08:38 UTC
The filter works well
4.5.0-0.nightly-2020-05-06-011431

Comment 5 errata-xmlrpc 2020-07-13 17:26:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.