Bug 182327 - anaconda starts X on wrong screen
anaconda starts X on wrong screen
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 15:59 EST by C. Dominik Bodi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 02:49:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description C. Dominik Bodi 2006-02-21 15:59:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
I have a Targa Traveller 826 laptop that comes with a VGA and S-Video output besides the built-in LCD display. The gfx chipset is a Mobility Radeon X700.
When anaconds starts up, X get's started on the external VGA output. The built-in LCD remains black.

This seems to be a bug the the new x.org 6.9 release, I have seen this with other distros using xorg 6.9 or 7.0, as well. Usually, an appropriate "MonitorLayout" override in xorg.conf helps, but I don't know how to do that with the installer dvd. As not many other's have seen this bug, it may well be h/w specific.

Unfortunetly, the text based interface uses the LCD, but it seems to be broken. I cannot install FC5-test3 atm.

Using the options "noprobe", "skipddc", "nofb" did not help.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Buy a Targa Traveller 826.
2. Insert DVD and reboot.
3. Press enter at the boot menu to start anaconda in gfx mode.
  

Actual Results:  The built-in LCD was blank.

Expected Results:  The built-in LCD should have displayed the Anaconda GUI.

Additional info:

I've seen this on other distros using xorg 6.9 or 7.0. For instance, see https://launchpad.net/distros/ubuntu/+source/xserver-xorg-driver-ati/+bug/31009
Comment 1 C. Dominik Bodi 2006-02-21 16:05:12 EST
I just checked the /tmp/X.log file, and it doesn't seem to be that simple.
There's an error message in the file:
"[drm] failed to load kernel module "radeon"
(EE) RADEON(0): [dri] DRIScreenInit failed. Disabling DRI."

Perhaps that's why X is resorts to use the VGA output instead.
Comment 2 Mike A. Harris 2006-02-22 20:52:35 EST
(In reply to comment #1)
> I just checked the /tmp/X.log file, and it doesn't seem to be that simple.
> There's an error message in the file:
> "[drm] failed to load kernel module "radeon"
> (EE) RADEON(0): [dri] DRIScreenInit failed. Disabling DRI."
> 
> Perhaps that's why X is resorts to use the VGA output instead.

No, that has nothing to do with it.  The installer does not have any need
for OpenGL, so the DRI X modules, and kernel DRM modules are not present
in the installer.  The X server will still try to find them and load them
however, as that's what it's compiled in defaults and configuration are
set to do.  If it can't find the modules, it just disables that functionality
and moves on.

The problem you are having is not related to this.
Comment 3 Mike A. Harris 2006-02-22 20:57:58 EST
The driver's built in autodetection sets one display as primary, and that
seems to be the opposite display that you'd prefer to have as primary.

The MonitorLayout option can override the driver's defaults as mentioned
above, and in the ubuntu URL posted.

Since this seems to be a general problem and not specific to Fedora Core,
please report it in X.Org bugzilla at http://bugs.freedesktop.org in the
"xorg" component.  Be sure to attach your X server log file and config
file to the report as individual uncompressed attachments so the driver
maintainer(s) have sufficient details to diagnose the problem.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 4 Mike A. Harris 2006-03-08 06:51:54 EST
ping
Comment 5 C. Dominik Bodi 2006-03-08 12:42:11 EST
sorry, I have been quite busy organising some Linux events in my home town. I'll
hopefully get around filing an upstream bug next week.

Regards,
Dominik
Comment 6 Mike A. Harris 2006-03-09 02:49:00 EST
No prob, just add a comment with the bug URL when you get a chance, and
we'll add it to our tracker.

Thanks in advance.
Comment 7 C. Dominik Bodi 2006-03-17 16:11:54 EST
https://bugs.freedesktop.org/show_bug.cgi?id=5473

Note You need to log in before you can comment on or make changes to this bug.