Bug 1823348
| Summary: | Attaching CDROM to a VM from an ISO residing on a block domain fails | ||
|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Tal Nisan <tnisan> |
| Component: | BLL.Storage | Assignee: | Tal Nisan <tnisan> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Evelina Shames <eshames> |
| Severity: | high | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 4.4.0 | CC: | bugs, eshames, michal.skrivanek |
| Target Milestone: | ovirt-4.4.0 | Flags: | pm-rhel:
ovirt-4.4+
|
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | ovirt-engine-4.4.0_beta4 | Doc Type: | No Doc Update |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2020-05-20 20:03:15 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | Storage | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Tal Nisan
2020-04-13 12:23:52 UTC
Apparently setting a startup policy on a block device causes the device to be dropped, from Libvirt logs: 2020-04-13 11:57:38.657+0000: 21156: error : virDomainDiskTranslateSourcePool:31750 : XML error: 'startupPolicy' is only valid for 'file' type volume 2020-04-13 11:57:38.657+0000: 21156: debug : qemuDomainCheckRemoveOptionalDisk:11104 : Dropping disk 'hdc' on domain 'derba' (UUID 'f9ce316c-7b8d-45f2-a340-47a0eaa8c5c1') due to inaccessible source '/rhev/data-center/mnt/blockSD/a326bbc...' This is caused due to a change in Libvirt enforcing the startup policy to hard, fixed in bug 1811728, however this shouldn't be set for a block device either way so the correct fix will be to remove it completely in case of a block device CDROM Verified on engine-4.4.0-0.33.master.el8ev. This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020. Since the problem described in this bug report should be resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE. If the solution does not work for you, please open a new bug report. |