Bug 182341 - Manual network config results in no gateway or default route
Manual network config results in no gateway or default route
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 17:21 EST by Robert Nichols
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 23:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Nichols 2006-02-21 17:21:48 EST
Description of problem:
When configuring an Ethernet manually (no DHCP), the resulting network
configuration lacks any default route or gateway address.

Version-Release number of selected component (if applicable):
anaconda-10.92.5-1

How reproducible:
always

Steps to Reproduce:
1. Begin a new installation of FC5 test 3 on a machine with an Ethernet interface.
2. In the configuration for eth0, remove the checkmark for using DHCP and
manually enter the IP address, netmask, gateway, and DNS server addresses.
3. Finish the rest of the installation.
  
Actual results:
When the installed system boots, the network has no gateway or default route
configured.  This renders external networking essentially inoperative.

Expected results:
Since eth0 is the only interface, the resulting network configuration should
have eth0 as the default route and with the supplied gateway address.

Additional info:
Comment 1 Robert Nichols 2006-02-21 23:49:28 EST
OK, unless somebody else runs into this let's forget it.  I can no longer
reproduce the problem.  I have no idea what was different the first two times I
tried the installation.

Note You need to log in before you can comment on or make changes to this bug.