Bug 1823487 - Running "openshift-install create manifests" creates a new server group in cloud without removing it.
Summary: Running "openshift-install create manifests" creates a new server group in cl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-13 19:57 UTC by Adolfo Duarte
Modified: 2020-07-13 17:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: "openshift-install create manifests" created a Nova server group as a side effect Consequence: If the cluster is not really created after "create manifests", then one resource is leaked in the OpenStack cluster. Fix: The server group is now created alongside every other resource, in the proper installation step Result: "create manifests" has no side effects on the OpenStack infrastructure any more.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-openstack pull 97 0 None closed Bug 1823487: Add ServerGroupName to OpenstackProviderSpec 2020-09-14 13:55:23 UTC
Github openshift installer pull 3655 0 None closed Bug 1823487: openstack: Pass the master server group by name 2020-09-14 13:55:22 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:27:45 UTC

Description Adolfo Duarte 2020-04-13 19:57:06 UTC
Description of problem:

When the command "openshift-install create manifests" is run, a new server group is created in the cloud specified in clouds.yaml file. The server group is not deleted. This could lead to resource leaking, since the "create manifests" command could be executed several times by user without them knowing the server group is being created. 


How reproducible: always. 


Steps to Reproduce:
1. with a valid clouds.yaml file and a valid install-config.yaml file execute the command: "openshift-install create manifests"
2 Check the openstack cloud with "openstack server group list" you will see a new server group has been created using the  infraID
3.

Actual results:
server group is created but not deleted.

Expected results:
After the command is executed, there should be no server group present in the cloud. 

Additional inf

Comment 1 Pierre Prinetti 2020-05-14 14:33:57 UTC
Planning to fix during this sprint.

Comment 5 David Sanz 2020-06-01 10:08:02 UTC
Verified on 4.5.0-0.nightly-2020-06-01-081609

[morenod@morenod-laptop manifests]$ cat install-config.yaml | grep -A2 metadata
metadata:
  creationTimestamp: null
  name: morenod-0106
[morenod@morenod-laptop manifests]$ openstack server group list | grep morenod
[morenod@morenod-laptop manifests]$ ./openshift-install create manifests
INFO Credentials loaded from file "/home/morenod/OCP/manifests/clouds.yaml" 
INFO Consuming Install Config from target directory 
[morenod@morenod-laptop manifests]$ openstack server group list | grep morenod
[morenod@morenod-laptop manifests]$

Comment 6 errata-xmlrpc 2020-07-13 17:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.