Bug 1823678 - Tiled (usually 5k) monitors doesn't work properly
Summary: Tiled (usually 5k) monitors doesn't work properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonas Ådahl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F32FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-04-14 09:09 UTC by Jonas Ådahl
Modified: 2020-04-23 18:02 UTC (History)
13 users (show)

Fixed In Version: mutter-3.36.1-5.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-23 18:02:38 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/mutter - issues 1170 None None None 2020-04-14 09:10:26 UTC

Description Jonas Ådahl 2020-04-14 09:09:48 UTC
Description of problem:

Tiled monitors shows half the monitor content on both tiles.

How reproducible:

1. Plug in tiled monitor.


Actual results:

Each tile of the monitor (half/half) shows the content of the first tile.

Expected results:

The monitor shows the content appropriately.

Additional info:

This is a fairy rare setup, requiring high end monitors.

Comment 1 Jonas Ådahl 2020-04-14 09:10:26 UTC
Attempted fix: https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1199

Comment 2 Jonas Ådahl 2020-04-14 09:19:15 UTC
Scratch build available at https://koji.fedoraproject.org/koji/taskinfo?taskID=43379125

Comment 3 Jonas Ådahl 2020-04-14 09:20:19 UTC
(In reply to Jonas Ådahl from comment #2)
> Scratch build available at
> https://koji.fedoraproject.org/koji/taskinfo?taskID=43379125

Hans, could you check that this build doesn't break anything with a panel orientation?

Comment 4 Hans de Goede 2020-04-14 13:39:26 UTC
(In reply to Jonas Ådahl from comment #3)
> Hans, could you check that this build doesn't break anything with a panel
> orientation?

Just tested this, works fine for me, including using an external (unrotated) monitor.

Thank you for checking with me that this did not break.

Comment 5 Jonas Ådahl 2020-04-14 19:23:56 UTC
(In reply to Hans de Goede from comment #4)
> (In reply to Jonas Ådahl from comment #3)
> > Hans, could you check that this build doesn't break anything with a panel
> > orientation?
> 
> Just tested this, works fine for me, including using an external (unrotated)
> monitor.
> 
> Thank you for checking with me that this did not break.

The merge request is verified to fix the immediate issue, but was not complete, thus I gave it a second try to fix more edge cases. Could you sanity test this as well? Scratch build available here: https://koji.fedoraproject.org/koji/taskinfo?taskID=43397439

Comment 6 Fedora Blocker Bugs Application 2020-04-15 06:32:22 UTC
Proposed as a Freeze Exception for 32-final by Fedora user jadahl using the blocker tracking app because:

 High end 5K monitors sometimes are constructed as multiple display panels "tiled" inside a physical monitor. To the operating system they appear as multiple separate monitors with some metadata that tie them together. in GNOME this metadata is constructed to create a single monitor for multiple tiled monitor outputs.

This functionality broke with GNOME 3.36, where booting into a system which used such a high end monitor would result in an unusable desktop.

Bug 1823678 contains a fix that verified by a bug reporter upstream to fix the issue. An early version of the fix has been verified to not regress on another relatively rare hardware setup that share the same code paths, and it has been regression with a more common hardware setup (laptop and external monitor) tested by me.

Note that these high end monitors are rare and usually expensive, but do exist, and we've seen bug reports about them in Fedora in the past.

Comment 7 Ben Cotton 2020-04-15 14:52:37 UTC
-1 FE for now. It seems like the fix is still in progress and would be better off landing as a post-release update. I might change to +1 FE if the release slips and a fully-formed fix is available.

Comment 8 Adam Williamson 2020-04-15 15:27:52 UTC
I'm +1 FE as I trust the devs not to send an update till the fix is complete and properly reviewed, they have a good process upstream for this. Of course, if RC 1.3 is approved this can't go in.

Comment 9 Jonas Ådahl 2020-04-15 15:30:54 UTC
(In reply to Ben Cotton from comment #7)
> -1 FE for now. It seems like the fix is still in progress and would be
> better off landing as a post-release update. I might change to +1 FE if the
> release slips and a fully-formed fix is available.

The upstream fix has been verified and reviewed and is about to land, so it should be considered finished.

Comment 10 Hans de Goede 2020-04-15 16:33:34 UTC
(In reply to Jonas Ådahl from comment #5)
> The merge request is verified to fix the immediate issue, but was not
> complete, thus I gave it a second try to fix more edge cases. Could you
> sanity test this as well? Scratch build available here:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=43397439

I've out this build through the same tests as before, everything still works fine for me.

Comment 11 Stephen Gallagher 2020-04-15 20:57:40 UTC
I'm +1 FE for this, but whether it goes in will depend on the Go/No-Go decision tomorrow on RC 1.3

Comment 12 Lukas Ruzicka 2020-04-20 10:48:32 UTC
As we were No-Go last week, I am +1 for FE now.

Comment 13 Fedora Update System 2020-04-20 16:54:29 UTC
FEDORA-2020-beac641efe has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-beac641efe

Comment 14 Geoffrey Marr 2020-04-20 17:47:55 UTC
Discussed during the 2020-04-20 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-04-20/f32-blocker-review.2020-04-20-16.01.txt

Comment 15 Fedora Update System 2020-04-21 18:43:14 UTC
FEDORA-2020-beac641efe has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-beac641efe`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-beac641efe

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2020-04-23 18:02:38 UTC
FEDORA-2020-beac641efe has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.