Bug 182368 - iiimd grabs swap space suddenly when Firefox is being used
iiimd grabs swap space suddenly when Firefox is being used
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 21:05 EST by Jim Breen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 12.2-4.fc4.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 00:17:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Breen 2006-02-21 21:05:15 EST
Description of problem:

I have IIIMF enabled for Japanese input, and am using Firefox 1.0.7
as a browser. Typically the IM is not active - I only turn it on
when entering Japanese text. It sits on the bar as [Ja]. I only have to 
click on a few links in WWW pages in Firefox and suddenly the disk becomes
very active and "top"  shows that iiimd is rapidly growing. If I let it go
it uses my whole 1Gb  swap partition (currently I have a ulimit on the
init.d script to kill iiimd at 256Mb).

Note that it does *not* occur when entering Japanese or other text
in Firefox, and it does not happen when using Japanese-capable
apps such as gnome-terminal, mlterm, ebview, etc.

Version-Release number of selected component (if applicable):

Firefox 1.0.7

iiimf - don't know - whatever came on the fc4 CDs.

How reproducible:

Happens every time.

Steps to Reproduce:
1.make sure iiimd is running (I have it on my task bar - Gimlet)
2.click a few links in Firefox
  
Actual results:

See above.

Expected results:

Correct behaviour of iiimd

Additional info:
Comment 1 Jim Breen 2006-02-28 02:27:44 EST
An update.

Since posting that bug, I ran up2date over my system (something I
should have done before posting). I see it brought in a number of
iiimf rpms.

Since then the runaway swapspace problem with iiimd has not
occurred again.
Comment 2 Akira TAGOH 2006-03-06 06:03:00 EST
Comment #1:
To clarify, does it mean you have never seen this problem after updating the
package to the latest one?
Comment 3 Jim Breen 2006-03-06 19:21:48 EST
Correct. I can no longer reproduce the problem. I suggest it be dropped,
as it has probably been fixed already. Sorry.
Comment 4 Akira TAGOH 2006-03-07 00:17:54 EST
ok, so please reopen this if you see it again. closing now.

Note You need to log in before you can comment on or make changes to this bug.