Bug 1823792 - `oc explain authentication.spec --api-version config.openshift.io/v1` still shows "The default is auth.openshift.io"
Summary: `oc explain authentication.spec --api-version config.openshift.io/v1` still s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Maru Newby
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1825194
TreeView+ depends on / blocked
 
Reported: 2020-04-14 14:05 UTC by Xingxing Xia
Modified: 2020-07-13 17:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1825194 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:27:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:27:47 UTC

Description Xingxing Xia 2020-04-14 14:05:25 UTC
Description of problem:
`oc explain authentication.spec --api-version config.openshift.io/v1` still shows "The default is auth.openshift.io" in the version verified in bug 1819246.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-13-213244

How reproducible:
Always

Steps to Reproduce:
1. $ oc explain authentication.spec --api-version config.openshift.io/v1
...
   serviceAccountIssuer <string>
     serviceAccountIssuer is the identifier of the bound service account token
     issuer. The default is auth.openshift.io
...

Actual results:
1. still shows "The default is auth.openshift.io".

Expected results:
1. should show what bug 1819246 expects.

Comment 1 Xingxing Xia 2020-04-14 14:12:11 UTC
Looks like the bump of bug 1819246 's https://github.com/openshift/api/pull/617 was not done yet.

Comment 2 Maru Newby 2020-04-14 15:48:25 UTC
(In reply to Xingxing Xia from comment #1)
> Looks like the bump of bug 1819246 's
> https://github.com/openshift/api/pull/617 was not done yet.

Yes, I missed the bump. Another PR has already performed the bump, though, so verification of the default in the crd doc is now ready for your review. The 4.4 change will include the bump.

Comment 5 Xingxing Xia 2020-04-22 02:52:42 UTC
Verified in 4.5.0-0.nightly-2020-04-21-103613 with original steps, showing "The default is https://kubernetes.default.svc".

Comment 6 errata-xmlrpc 2020-07-13 17:27:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.