Bug 1823855 - Helm : values.yaml order is lost and comments stripped
Summary: Helm : values.yaml order is lost and comments stripped
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.4.z
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1823854
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-14 15:59 UTC by Rohit Rai
Modified: 2020-05-26 16:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1823854
Environment:
Last Closed: 2020-05-26 16:50:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5117 None closed [release-4.4] Bug 1823855: Use ordered-values.yaml in Helm install 2020-06-18 13:37:54 UTC
Red Hat Product Errata RHBA-2020:2180 None None None 2020-05-26 16:50:45 UTC

Description Rohit Rai 2020-04-14 15:59:07 UTC
+++ This bug was initially created as a clone of Bug #1823854 +++

Description of problem: 
The values.yaml content displayed on install is re-ordered with comments stripped. Removal of comments and re-ordering is concerning for following reasons :
1. global and / or common parameters which need to be updated by user aren't displayed at top
2. comments to guide users input are removed (thisincludes license acceptance text and pointer to README.MD externally hosted as not displayed during install flow in 4.4)
3. parameter order doesn't follow install documentation



Version-Release number of selected component (if applicable):


How reproducible: Always

Steps to Reproduce:
1. Go to developer catalog
2. Select a helm chart and click install

Actual results:
Values in the YAML editor are stripped off comments and loose the original order.

Expected results:
Values in the YAML editor should have comments and have original order intact.

Additional info:

Comment 3 Gajanan More 2020-05-19 04:32:45 UTC
I have validated the bugzilla on the
Build: 4.4.0-0.ci-2020-05-18-222957
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified

Comment 5 errata-xmlrpc 2020-05-26 16:50:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2180


Note You need to log in before you can comment on or make changes to this bug.