Bug 1823967 - k8s.gcr.io/pause:3.1 is in use as a pause container sometimes [NEEDINFO]
Summary: k8s.gcr.io/pause:3.1 is in use as a pause container sometimes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.6.0
Assignee: Peter Hunt
QA Contact: Sunil Choudhary
URL:
Whiteboard:
Depends On:
Blocks: 1844276
TreeView+ depends on / blocked
 
Reported: 2020-04-14 22:12 UTC by Ryan Phillips
Modified: 2020-12-03 05:48 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:57:47 UTC
Target Upstream Version:
fshaikh: needinfo? (umohnani)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3712 0 None closed Bug 1823967: Add the --pod-infra-container-image flag to the kubelet service 2021-02-01 02:21:26 UTC
Github openshift machine-config-operator pull 1776 0 None closed Bug 1823967: Set the pod-infra-container-image flag in kubelet to ocp pause image 2021-02-01 02:21:26 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:58:06 UTC

Description Ryan Phillips 2020-04-14 22:12:03 UTC
Description of problem:
master logs in this CI build sometimes contain k8s.gcr.io/pause:3.1 pause container references: https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-gcp-serial-4.5/775

Version-Release number of selected component (if applicable):
4.5

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
We use our own pause container, so a gcr reference is odd.

Expected results:


Additional info:

Comment 1 Ryan Phillips 2020-04-14 22:12:45 UTC
A test needs to be written so we do not regress.

Comment 10 Sunil Choudhary 2020-06-09 15:03:32 UTC
Pod infra container image is set to openshift release image from quay.io

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-06-09-101928   True        False         6m27s   Cluster version is 4.6.0-0.nightly-2020-06-09-101928

$ oc get nodes
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-131-204.us-east-2.compute.internal   Ready    worker   17m   v1.18.3+a637491
ip-10-0-154-245.us-east-2.compute.internal   Ready    master   29m   v1.18.3+a637491
ip-10-0-169-119.us-east-2.compute.internal   Ready    worker   17m   v1.18.3+a637491
ip-10-0-174-32.us-east-2.compute.internal    Ready    master   29m   v1.18.3+a637491
ip-10-0-192-208.us-east-2.compute.internal   Ready    master   29m   v1.18.3+a637491
ip-10-0-197-132.us-east-2.compute.internal   Ready    worker   17m   v1.18.3+a637491

$ oc debug node/ip-10-0-131-204.us-east-2.compute.internal
Starting pod/ip-10-0-131-204us-east-2computeinternal-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.0.131.204
If you don't see a command prompt, try pressing enter.
sh-4.2# chroot /host

sh-4.4# journalctl -u kubelet | grep -i pod-infra-container-image
Jun 09 14:41:51 ip-10-0-131-204 hyperkube[1461]: I0609 14:41:51.883261    1461 flags.go:33] FLAG: --pod-infra-container-image="quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:5c12b0ffaa08b00f1a46e879b72513dca7cc28ce2b361f6d5f0496fca21e3eb3"
Jun 09 14:41:51 ip-10-0-131-204 hyperkube[1461]: W0609 14:41:51.885506    1461 server.go:192] Warning: For remote container runtime, --pod-infra-container-image is ignored in kubelet, which should be set in that remote runtime instead

Comment 15 errata-xmlrpc 2020-10-27 15:57:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.