Bug 182398 - amavisd-new shouldn't require installed clamav
Summary: amavisd-new shouldn't require installed clamav
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: amavisd-new   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-22 11:36 UTC by Maxim Britov
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 20:22:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Maxim Britov 2006-02-22 11:36:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
Currently it have:
$ rpm -qp --requires amavisd-new-2.3.3-5.fc5.noarch.rpm |fgrep -i clam
/etc/clamd.d
/usr/sbin/clamd

I think it wrong. I use my own clamav configs and amavisd-new can use many another  AV tools.

Version-Release number of selected component (if applicable):
amavisd-new-2.3.3-5.fc5

How reproducible:
Always

Steps to Reproduce:
1.rpm -i amavisd-new-2.3.3-5.fc5.noarch.rpm
2. get deps bug
3.
  

Additional info:

Comment 1 Steven Pritchard 2006-02-22 20:22:43 UTC
Sorry, I couldn't disagree more.  Not pulling in clamav makes as much sense as
not pulling in spamassassin.  The extra dependencies are a feature, not a bug.

There is nothing stopping you from rewriting the amavisd config files,
installing your own clamav, etc.  Adding other AV scanners is easy too (just an
edit of the amavisd config file).  I personally use BitDefender and/or AVG on
some of my systems.

Comment 2 Maxim Britov 2006-02-23 08:16:27 UTC
Ok, may you should remove /etc/clamd.d deps and left only /usr/sbin/clamd deps?


Note You need to log in before you can comment on or make changes to this bug.