Bug 1823993 - etcd: fix deadlock in grpclb connection cache
Summary: etcd: fix deadlock in grpclb connection cache
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-15 02:02 UTC by Sam Batschelet
Modified: 2020-07-13 17:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: gRPC-go 1.23.0 had a bug in client loadbalancer Consequence: This could result in deadlock Fix: gRPC-go is bumped to use patched v1.23.1 Result: The conditions for client loadbalancer resulting in deadlock are no longer there.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:27:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift etcd pull 44 None closed *: bump etcd to v3.4.7 2020-06-28 02:30:11 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:28:20 UTC

Description Sam Batschelet 2020-04-15 02:02:05 UTC
Description of problem: gRPC-go 1.23.0 had a bug in client loadbalancer which could result in deadlock[1]

[1] https://github.com/grpc/grpc-go/pull/3017


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: gRPC-go is unpatched v1.23.0


Expected results: gRPC-go is bumped to use patched v1.23.1


Additional info:

Comment 2 Michal Fojtik 2020-05-18 07:29:25 UTC
This bug hasn't had any activity in the last 30 days. Maybe the problem got resolved, was a duplicate of something else, or became less pressing for some reason - or maybe it's still relevant but just hasn't been looked at yet. As such, we're marking this bug as "LifecycleStale" and decreasing the severity/priority. If you have further information on the current state of the bug, please update it, otherwise this bug can be closed in about 7 days. The information can be, for example, that the problem still occurs, that you still want the feature, that more information is needed, or that the bug is (for whatever reason) no longer relevant.

Comment 9 errata-xmlrpc 2020-07-13 17:27:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.