This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 182423 - Doc. Notes + resource agent for Oracle 10g Database Failover
Doc. Notes + resource agent for Oracle 10g Database Failover
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
: Documentation, FutureFeature, OtherQA, Reopened
Depends On: 333191
Blocks: 349561 349571
  Show dependency treegraph
 
Reported: 2006-02-22 09:29 EST by Lon Hohberger
Modified: 2009-04-16 16:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0791
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:15:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Starting point - Modified Oracle 10g iAS CFC script from certification on RHEL2.1/RHCS3 (17.12 KB, text/plain)
2006-02-22 09:29 EST, Lon Hohberger
no flags Details
first draft of a howto (2.06 MB, application/octet-stream)
2006-02-27 20:11 EST, Lon Hohberger
no flags Details

  None (edit)
Description Lon Hohberger 2006-02-22 09:29:18 EST
Description of problem:

There is nothing in the RHCS4 documentation or tools which aids users with
installing install Oracle 10g in CFC (Cold failover cluster) environments.
Comment 1 Lon Hohberger 2006-02-22 09:29:18 EST
Created attachment 125031 [details]
Starting point - Modified Oracle 10g iAS CFC script from certification on RHEL2.1/RHCS3
Comment 2 Suvankar Moitra 2006-02-27 00:54:47 EST
Pl put a document for oracle 10g installation in RHCS4 cluster .
Comment 3 Suvankar Moitra 2006-02-27 00:58:55 EST
Pl put a document for oracle 10g installation in RHCS4 2node active/passive 
cluster.
Comment 4 Lon Hohberger 2006-02-27 13:15:53 EST
The OUI_HOSTNAME=xxx parameter as documented here:

http://www.oracle.com/technology/deploy/availability/pdf/MAA_WP_10gEMAgentActivePassive.pdf

...does not seem to apply to 10gR2 generally - only the EM component.
Comment 5 Lon Hohberger 2006-02-27 20:11:46 EST
Created attachment 125371 [details]
first draft of a howto

Requires a web browser.  Also requires at least RHEL4U2 and RHCS4U2.
Comment 6 Suvankar Moitra 2006-03-03 01:56:43 EST
(In reply to comment #2)
> Pl put a document for oracle 10g installation in RHCS4 cluster .

dear lon ,

I think it will help me.If any further requirment is there i will mail you.

regards

Suvankar
Comment 7 Lon Hohberger 2006-03-03 10:25:00 EST
Place all comments (things that work, things that do not work) in this bugzilla.
Comment 9 Lon Hohberger 2006-07-20 14:36:54 EDT
Oracle 10g Release 2 ships with the ability to run Oracle Clusterware and set up
a single-instance databases for failover in cluster environments.  

Using RHCS to do this is, therefore, not necessary.
Comment 10 Robinson Maureira 2006-08-01 16:40:45 EDT
I've setup a similar environment in a customer, following this howto, but after
updating to RHEL4U3 I cannot longer preload hostname.so, therefore there's no
way to enable iSQL and EM.

The error message is that java is unable to preload hostname.so

Any hints on what to correct? I've already recompiled the file, following script
code.

Regards
Comment 12 Lon Hohberger 2008-01-16 18:01:18 EST
I've updated the agent and notes:

http://people.redhat.com/lhh/oracle-rhel5-notes-0.6/oracledb.sh
http://people.redhat.com/lhh/oracle-rhel5-notes-0.6/oracle-notes.html

The updates were targeted for RHEL5, but should also apply to RHEL4 (since it's
the same doc + agent + application + version - i.e. still Oracle 10g Release 2)

Those who followed the older guide should only need to update their resource agent .
Comment 13 Suvankar Moitra 2008-01-22 06:48:29 EST
Hi,

From one node if you run the command emca ( please see the option its like : 
emca recreate dbconsole ) from both the nodes one by one , but besure when you 
run the command the db should be control of that node.

regards

Suvankar 

(In reply to comment #10)
> I've setup a similar environment in a customer, following this howto, but 
after
> updating to RHEL4U3 I cannot longer preload hostname.so, therefore there's no
> way to enable iSQL and EM.
> The error message is that java is unable to preload hostname.so
> Any hints on what to correct? I've already recompiled the file, following 
script
> code.
> Regards

Comment 14 Lon Hohberger 2008-01-29 16:24:14 EST
Also, per comment #10 - the new agent I noted in comment #12 does not use
preloading.

-- Lon
Comment 17 errata-xmlrpc 2008-07-25 15:15:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0791.html

Note You need to log in before you can comment on or make changes to this bug.