Bug 1824324 - initscripts: incompatibility with grep 3.2+
Summary: initscripts: incompatibility with grep 3.2+
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: initscripts
Version: CentOS Stream
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Jan Macku
QA Contact: Daniel Rusek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-15 20:40 UTC by Carl George 🤠
Modified: 2020-11-04 01:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 01:41:25 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4463 0 None None None 2020-11-04 01:41:39 UTC

Description Carl George 🤠 2020-04-15 20:40:01 UTC
Description of problem:
Initscripts prior to 10.03 has a bug when used with grep 3.2 or newer.

https://github.com/fedora-sysv/initscripts/issues/300
https://github.com/fedora-sysv/initscripts/pull/301

CentOS 8 and RHEL 8 are using initscripts 10.00.6 and grep 3.1, but some users choose to upgrade to a newer version of grep on their own and hit this bug.  This will also be a problem if RHEL chooses to rebase grep or backport that behavior in the future.

Version-Release number of selected component (if applicable):
initscripts-10.00.6-1.el8


Additional info:
The community has offered a backport already.

https://git.centos.org/rpms/initscripts/pull-request/1
https://git.centos.org/fork/dcavalca/rpms/initscripts/c/dd24befa34ad30d777a3d3fa6c076be47777e8cc.patch

Comment 1 Carl George 🤠 2020-04-15 20:46:26 UTC
Please disregard that last link in the additional info.  That's a patch that would apply to the CentOS initscripts package source, not to the initscripts source itself.  The appropriate patch to apply in the RHEL spec file would be the upstream one.

https://github.com/fedora-sysv/initscripts/commit/55ee446c0715b013e6d54860ae65e55baf544dc3.patch

Comment 2 Jan Macku 2020-04-16 06:32:18 UTC
Hi Carl,
thank you, I completely forgot about this issue. I'll backport it from upstream. I should make it into RHEL 8.3.0.

Jan

Comment 3 Jan Macku 2020-04-16 08:03:47 UTC
Upstream PR: https://github.com/fedora-sysv/initscripts/pull/317

Comment 5 Davide Cavalca 2020-05-20 15:34:53 UTC
Any update on this? fwiw I had a chat with grep upstream and they've confirmed the PR will properly mitigate this issue.

Comment 6 Lukáš Nykrýn 2020-05-20 15:45:29 UTC
(In reply to Davide Cavalca from comment #5)
> Any update on this? fwiw I had a chat with grep upstream and they've
> confirmed the PR will properly mitigate this issue.

The fix is planned for 8.3.

Comment 12 errata-xmlrpc 2020-11-04 01:41:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (initscripts bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4463


Note You need to log in before you can comment on or make changes to this bug.