Bug 1824356 - No filters shown on Role Bindings page
Summary: No filters shown on Role Bindings page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Bipul Adhikari
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-16 01:52 UTC by Yadan Pei
Modified: 2020-07-13 17:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:27:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5077 0 None closed Bug 1824356: Add support for new toolbar in remaining pages 2020-06-23 10:03:35 UTC
Github openshift console pull 5127 0 None closed Bug 1824356: Fix Role Binding filter issue 2020-06-23 10:03:35 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:28:28 UTC

Description Yadan Pei 2020-04-16 01:52:55 UTC
Description of problem:
Click 'Filter' button on Role Bindings page, console don't show any filters, the dropdown is blank

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-15-194358

How reproducible:
Always

Steps to Reproduce:
1. cluster-admin user goes to User Management -> Role Bindings page, click the Filter button
2.
3.

Actual results:
1. dropdown list is blank

Expected results:
1. It should show 'Cluster-wide Role Bindings', 'Namespace Role Bindings' and 'System Role Bindings'

Additional info:

Comment 3 shahan 2020-04-21 10:06:35 UTC
The button will show 'Cluster-wide Role Bindings', 'Namespace Role Bindings' and 'System Role Bindings' However clicking any of it, will not filter out anything.
4.5.0-0.nightly-2020-04-18-184707

Comment 5 Yanping Zhang 2020-04-22 06:23:15 UTC
Checked on ocp 4.5 with payload 4.5.0-0.nightly-2020-04-21-103613, the result is the same with that in Comment 3.

Comment 6 Bipul Adhikari 2020-04-22 06:39:57 UTC
https://github.com/openshift/console/pull/5127 has screenshots of this working.

Comment 7 Yanping Zhang 2020-04-22 09:18:45 UTC
Just found the fix in pr 5127 is not contained in payload 4.5.0-0.nightly-2020-04-21-103613, will check again with new available payload.

Comment 8 Yanping Zhang 2020-04-23 03:20:50 UTC
Checked on 4.5 cluster with payload 4.5.0-0.ci-2020-04-22-212726, on User Management -> Role Bindings page, filter with 'Cluster-wide Role Bindings', 'Namespace Role Bindings' and 'System Role Bindings' will show correct result.
The bug is fixed, so move it to Verified.

Comment 9 errata-xmlrpc 2020-07-13 17:27:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.