Bug 182438 - There is a big problem with the encoding of the Bulgarian translation of man package
There is a big problem with the encoding of the Bulgarian translation of man ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 11:12 EST by Alexander Shopov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 03:13:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Shopov 2006-02-22 11:12:17 EST
Description of problem:


Version-Release number of selected component (if applicable):
Name        : man
Version     : 1.6c
Release     : 1.2  

How reproducible: Always since several versions of man


Steps to Reproduce:
1. In a Bulgarian locale gnome-terminal enter:
man man
OR
in en_EN.UTF-8 locale terminal enter:
LANG=bg_BG.UTF-8 man man

  
Actual results:
Gibberish in man - this is the man page of man, translated in Bulgarian - but it
has undergone a very strange recoding process - the cyrillic letters are all
mixed up - you do not need a Bulgarian speaker to verify that - any SLavic
Cyrillic user can verify that

Expected results: Normal Bulgarian translation of man

ANOTHER WAY TO REPORDUCE:
In 
in en_EN.UTF-8 locale gnome-terminal enter:

man NON_EXISTING_PAGE_JUST_TO_MAKE_MAN_OUTPUT_A_TRANSLATED_MESSAGE

Additional info:

I am the current maintainer of Bulgarian translation of man. I downloaded the
upstram package from here:
http://primates.ximian.com/~flucifredi/man/man-1.6c.tar.gz

I uncompressed it and checked - the original messages are properly encoded. The
Bulgarian versions use cp1251 and this has been properly announced in the package:

wget http://primates.ximian.com/~flucifredi/man/man-1.6c.tar.gz
tar xvfz man-1.6c.tar.gz


Files containing Bulgarian messages of man:
===========================================
man-1.6c/msgs/mess.bg -> Properly encoded in CP1251
man-1.6c/msgs/mess.bg.codeset -> Properly announced that the encoding is cp1251

Files containing Bulgarian translations of man pages:
man-1.6c/man/bg -> *.man -> Properly encoded in CP1251


After that - I downloaded your source package from here:
http://download.fedora.redhat.com/pub/fedora/linux/core/test/4.92/source/SRPMS/man-1.6c-1.2.src.rpm
I started looking into it.
If you take a look at this file man-1.6b-i18n_nroff.patch
Which is used as Patch21 in man spec file, you will find a line that reads:

+    { "bg",    "KOI8-R"     },

I think - this is wrong - the strongly preferred 8 bit encoding here, and the
one that is used in man translation is CP1251 (windows-1251).

I tried changing that and recompiling the man package, after which reinstalled
it and tried again:

man -c  man
man NON_EXISTING_PAGE_JUST_TO_MAKE_MAN_OUTPUT_A_TRANSLATED_MESSAGE


But the result did not change - man still gives gibberish
Comment 1 Ivana Varekova 2006-02-23 09:56:32 EST
The fixed test version of man package which should fix the problem with
bulgarian man pages is on:
http://people.redhat.com/varekova/man-1.6c-2.test.src.rpm
and
http://people.redhat.com/varekova/man-1.6c-2.test.i386.rpm.
Could you please test it?
Comment 2 Alexander Shopov 2006-02-23 11:44:10 EST
I've just downloaded and tested
http://people.redhat.com/varekova/man-1.6c-2.test.i386.rpm
and *confirm* that it fixes the problem.

Thank you very much Ivana for the prompt solution.
Comment 3 Ivana Varekova 2006-02-27 09:04:06 EST
Thank you for your detailed bug report and your test. 
This problem is fixed in man-1.6c-2. 
Comment 4 Alexander Shopov 2006-03-23 12:50:28 EST
I am reopening this bug as I get the same results with FC5

rpm -qa | grep man-1
man-1.6c-1.2

I get the exact same behaviour as before.
The reason is that the man package has not been updated to the rawhide version.
Could we get it via updates?
Comment 5 Ivana Varekova 2006-03-27 03:13:31 EST
Version man-1.6c-2.fc5 fixes this problem in fc5 now.

Note You need to log in before you can comment on or make changes to this bug.