Bug 182439 - xorg-x11-font-utils obsoletes itself?!?
xorg-x11-font-utils obsoletes itself?!?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-font-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 11:29 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 06:36:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-02-22 11:29:02 EST
Description of problem:
The self-obsoletion causes a bit of a problem when you update an x86_64 box: yum
will try to install both the i386 and the x86_64 versions of the package if you
have both i386 and x86_64 repos enabled.

I don't quite see what the point is of this self-obsoletes, so I thought I'd
point it out and see if this gets removed, making these useless updates go away.

Version-Release number of selected component (if applicable):
xorg-x11-font-utils-1.0.1-2

How reproducible:
Every time

Steps to Reproduce:
1.Install FC5T3 on an x86_64 box
2.Set up yum repos for rawhide i386 and x86_64, both enabled
3.Run yum update
  
Actual results:
it attempts to install the i386 version of xorg-x11-font-utils, in addition to
updating the x86_64 version, because of the obsoletes

Expected results:
No xorg-x11-font-utils.i386

Additional info:
Comment 1 Mike A. Harris 2006-02-24 06:36:51 EST
Indeed, very broken.  Fixed in latest package build.

Note You need to log in before you can comment on or make changes to this bug.