Bug 182441 - Plague is leaking mysql connections
Plague is leaking mysql connections
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plague (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 11:33 EST by Andreas Thienemann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 14:11:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2006-02-22 11:33:24 EST
After running plague-server (with the mysqld backend in my case) for a while,
the plague-server quits with the following message:

Error: (1040, 'Too many connections')

Grepping through the logs shows that this seems to happen somewhere in the
depsolver code, as the error appears after a started depsolver or a finished
depsolver action.

The error itself is coming from the mysql server, which has a connection limit
of 100 concurrent connections.

Calling show-processlist on the mysql server gives the following output:

mysql> show processlist;
+----+--------+-------------------------+--------+---------+------+-------+------------------+
| Id | User   | Host                    | db     | Command | Time | State | Info
            |
+----+--------+-------------------------+--------+---------+------+-------+------------------+
|  3 | plague | horscht.bawue.net:49928 | plague | Sleep   |  886 |       | NULL
            |
| 13 | plague | horscht.bawue.net:49949 | plague | Sleep   |   37 |       | NULL
            |
| 20 | plague | horscht.bawue.net:49990 | plague | Sleep   |  746 |       | NULL
            |
| 23 | plague | horscht.bawue.net:49991 | plague | Sleep   |  741 |       | NULL
            |
| 24 | plague | horscht.bawue.net:49992 | plague | Sleep   |  740 |       | NULL
            |
| 25 | plague | horscht.bawue.net:49999 | plague | Sleep   |  735 |       | NULL
            |
| 27 | plague | horscht.bawue.net:50002 | plague | Sleep   |  730 |       | NULL
            |
| 33 | plague | horscht.bawue.net:50006 | plague | Sleep   |  708 |       | NULL
            |
| 34 | plague | horscht.bawue.net:50008 | plague | Sleep   |  703 |       | NULL
            |
| 35 | plague | horscht.bawue.net:50011 | plague | Sleep   |  692 |       | NULL
            |
| 36 | plague | horscht.bawue.net:50012 | plague | Sleep   |  687 |       | NULL
            |
| 55 | plague | horscht.bawue.net:50092 | plague | Sleep   |  528 |       | NULL
            |
| 56 | plague | horscht.bawue.net:50093 | plague | Sleep   |  523 |       | NULL
            |
| 57 | plague | horscht.bawue.net:50097 | plague | Sleep   |  512 |       | NULL
            |
| 58 | plague | horscht.bawue.net:50098 | plague | Sleep   |  507 |       | NULL
            |
| 79 | root   | horscht.bawue.net:50350 | NULL   | Query   |    0 | NULL  | show
processlist |
+----+--------+-------------------------+--------+---------+------+-------+------------------+
Comment 1 Dan Williams 2006-03-12 08:41:38 EST
Can you report (again) which mysql and which MySQL-python package versions
you're using?
Comment 2 Andreas Thienemann 2006-03-20 09:43:12 EST
mysql-4.1.10a-2.RHEL4.1
MySQL-python-1.0.0-1.RHEL4.1
Comment 3 Dan Williams 2006-03-20 15:08:59 EST
Confirmed here on a RHEL4 U3 system, looking into the cause.
Comment 4 Dan Williams 2006-03-24 14:11:19 EST
Should be fixed in CVS HEAD and also on STABLE_4 branch.

Note You need to log in before you can comment on or make changes to this bug.