Bug 182442 - PCI soundcard unusable after sw/component upgrade
PCI soundcard unusable after sw/component upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 11:33 EST by John Chendra
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-04 18:42:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The log file that the error produce (15.97 KB, text/plain)
2006-02-22 11:33 EST, John Chendra
no flags Details
proposed patch for FC4 kernel, it's fixed in 11.rc3 (307 bytes, patch)
2006-02-23 07:44 EST, Martin Stransky
no flags Details | Diff

  None (edit)
Description John Chendra 2006-02-22 11:33:54 EST
Description of problem:
My PCI Soundcard, Creative Soundblaster is not functional, altough it's
recognized by the kernel (available for configuration, and in kernel module)
My on-board sound (Intel ICH5) is on the other hand configurable and usable.
This problem occured since I upgrade to kernel-2.6.15-1.1831_FC4 and
kernel-smp-2.6.15-1.1831_FC4, and alsa-lib-1.0.10-3.FC4 (don't know which, I
have tried to downgrade the alsa-lib and kernel, but the result is the same)

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. open up the soundcard detection
2. click on the play test sound
3. there's no sound output
  
Actual results:
Error notice

Expected results:
The sound played to my headphone/speaker

Additional info:
I've tried using Knoppix, Suse, Mandriva, ubuntu (install them on other
harddrive), there's no problem like this. I'm having the same problem with FC5
Test 2. I'm not really sure this is alsa-lib's problem/bug, but I don't know
which component is really causing this problem. I'm attaching the log file of
the error message. The error message send me here.. I'm sorry for my bad
english. Thank You
Comment 1 John Chendra 2006-02-22 11:33:54 EST
Created attachment 125036 [details]
The log file that the error produce
Comment 2 Martin Stransky 2006-02-23 07:44:15 EST
Created attachment 125096 [details]
proposed patch for FC4 kernel, it's fixed in 11.rc3
Comment 3 Martin Stransky 2006-02-23 07:45:38 EST
It's a problem in driver, see:

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=1681

Comment 4 Dave Jones 2006-02-27 00:12:29 EST
this is fixed in the kernel update in progress at
http://people.redhat.com/davej/kernels/Fedora/FC-4/  which I hope to be pushing
live later this week.

Note You need to log in before you can comment on or make changes to this bug.