Bug 18245 - linuxconf-1.19r2-4 dumps core when started
Summary: linuxconf-1.19r2-4 dumps core when started
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-03 17:30 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core dump for linuxconf (2.62 MB, application/octet-stream)
2001-09-18 10:03 UTC, Matthew Darcy
no flags Details
Second core dump to compare against first core dump (2.64 MB, application/octet-stream)
2001-09-18 10:42 UTC, Matthew Darcy
no flags Details

Description Need Real Name 2000-10-03 17:30:17 UTC
upgraded to rh7.0 from 6.2

[root@pug pete]# /etc/rc.d/init.d/linuxconf start
Running Linuxconf hooks:                                   [  OK  ]
[root@pug pete]# linuxconf  
Segmentation fault (core dumped)

[root@pug pete]# rpm -q linuxconf
linuxconf-1.19r2-4

Comment 1 Sergio A. Kessler 2000-10-12 15:06:58 UTC
it happened to me too, workaround: delete /etc/conf.linuxconf
:(

Comment 2 Need Real Name 2000-10-16 22:53:51 UTC
It seems the linuxconf exe has been movet to /sbin from /bin. In an upgrade 
the /bin/linuxconf file is not replaced. Verify this by running /sbin/linuxconf.

Deleting the config file only lets linuxconf start withour any modules. If a 
module is attempted to load the prog core dumps because you have a 1.17 exe 
trying to load a 1.19 module. 

Better workaround:

run /sbin/linuxconf .... keep your config file


Comment 3 Matthew Darcy 2001-09-18 10:01:57 UTC
I have this problem running redhat 7.1 kernel 2.4.2-2 (default)
I can load linuxconf fine even in GUI mode but when ever I touch any of the 
network settings and press accept....segmentation fault, core dump.

I am stuck for a work around.


Comment 4 Matthew Darcy 2001-09-18 10:03:36 UTC
Created attachment 31982 [details]
core dump for linuxconf

Comment 5 Matthew Darcy 2001-09-18 10:42:36 UTC
Created attachment 31998 [details]
Second core dump to compare against first core dump

Comment 6 Brent Fox 2002-06-05 16:23:55 UTC
Closing because we don't ship linuxconf anymore

Comment 7 Red Hat Bugzilla 2006-02-21 18:47:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.