Bug 182459 - Build perl-Imager for FC-4
Build perl-Imager for FC-4
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Imager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 182461
  Show dependency treegraph
 
Reported: 2006-02-22 12:44 EST by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 18:23:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-02-22 12:44:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Galeon/2.0.0

Description of problem:
Build package for FC-4, Sprog requirement.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. yum install perl-Imager


  

Actual Results:  Does not install.

Expected Results:  Should install.

Additional info:
Comment 1 Gavin Henry 2006-02-25 17:58:37 EST
Test 30 fails. Investigating.
Comment 2 Alex Lancaster 2006-02-25 18:28:31 EST
Some info here:

http://www.nabble.com/Bug-335971:-FTBFS:-t-t30t1font-test-fails-t702507.html


Don't know how much of a help this is.  I notice it's the same version of t1lib
on FC-4 and FC-4.
Comment 3 Alex Lancaster 2006-02-26 18:27:32 EST
I can't rebuild perl-Imager on devel (FC-5) from the SRPM so it seems strange
that it could ever build on devel.  One (unfortunate) possibility is that since
gcc has been upgraded in between the first build of perl-Imager on devel (back
in late Sept. 2005) and now, something in the gcc version is making it fail.

gcc has also been upgraded (patched) on FC-4 in the mean time (although not a
major release, it may have backported some changes from the new gcc 4.1) and
that would maybe also explain the failure on FC-4.

I would try rebuilding perl-Imager on devel now to see if it will, in fact,
rebuild with the current gcc.

This is pure speculation, but rebuilding perl-Imager on devel should give us
more information.
Comment 4 Gavin Henry 2006-02-27 05:21:03 EST
I'll try Srog with out it then locally on FC-4 and get rid if it in devel to try.
Comment 5 Gavin Henry 2006-02-27 06:03:11 EST
I don't think perl-Imager is needed now.

Gavin.
Comment 6 Alex Lancaster 2006-02-27 11:28:55 EST
(In reply to comment #5)
> I don't think perl-Imager is needed now.

You mean for Sprog?  It should be built in any case, it has uses independent of
Sprog.

Comment 7 Alex Lancaster 2006-02-27 18:39:15 EST
As I suspected, perl-Imager failed a rebuild on FC-5:

http://buildsys.fedoraproject.org/build-status/job.psp?email=ghenry@suretecsystems.com&uid=5311

so this is almost certainly a compiler issue, because that's about the only
thing that has changed since the last (successful) build of perl-Imager.

Have you taken this issue upstream?  Perhaps they might know what's up.
Comment 8 Michael Schwendt 2006-02-27 20:04:36 EST
FYI, the test it fails in is t1lib related. t1lib in Extras has been
changed and rebuilt recently. If you install FC4's old t1lib-5.0.2-3
the test succeeds.

[qa@rawhide Imager-0.45]$ PERL_DL_NONLAZY=1 /usr/bin/perl
"-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')"
t/t30t1font.t 
t/t30t1font....ok                                                            
All tests successful.
Files=1, Tests=64,  2 wallclock secs ( 0.62 cusr +  0.20 csys =  0.82 CPU)
Comment 9 Gavin Henry 2006-02-28 04:23:03 EST
So, do I spec the old version?

Or speak to the t1lib packager?

Thanks.
Comment 10 Michael Schwendt 2006-02-28 05:23:11 EST
Narrow it down. Verify the t1lib packaging (%changelog). t1lib 5.1.0
is from May 2005, so rather old too.

Where the test fails, it checks whether it can turn on/off the t1lib.log
file during initialisation of t1lib. It fails in line 131 where it checks
whether t1lib initialisation created t1lib.log when given the necessary
parameter. After returning, it only checks whether the log file exists.
Why exactly it doesn't exist remains to be investigated.
Comment 11 Michael Schwendt 2006-02-28 05:39:19 EST
Here's the contents of t1lib.log when I initialise the library with
trivial C code:

(W) ScanConfigFile(): Could not open global configfile /usr/share/t1lib/t1lib.co
nfig
(W) ScanConfigFile(): Neither user's nor global Configfile has been found
(W) T1_InitLib(): Warning t1lib configuration file not found!
(W) intT1_scanFontDBase(): Font Database File FontDataBase not found!
(W) T1_InitLib(): Fatal error scanning Font Database File FontDataBase

Comment 12 Michael Schwendt 2006-02-28 06:03:11 EST
This perl-Imager test suite is incompatible with t1lib 5.1.0.

The thing it does is calling T1_InitLib(..) consecutively without
calling T1_CloseLib() inbetweeen. t1lib doesn't re-initialise itself
when doing that.

Maybe the newer Imager 0.47 fixes this?
http://cpan.provocation.net/authors/id/T/TO/TONYC/
Comment 13 Gavin Henry 2006-02-28 06:58:05 EST
Doh. Should have checked that.

Building etc.
Comment 14 Gavin Henry 2006-02-28 07:21:17 EST
Success on FC-4 and Devel

Cheers Michael.


At last! ;-)
Comment 15 Alex Lancaster 2006-02-28 18:23:26 EST
Great.  Closing bug.  OK, now on to figuring out why Sprog fails (bug #182461)
given that it doesn't require perl-Imager anymore.

Note You need to log in before you can comment on or make changes to this bug.