Bug 182492 - Software removal has a misleading message
Summary: Software removal has a misleading message
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 201416 (view as bug list)
Depends On:
Blocks: FC6Blocker
TreeView+ depends on / blocked
 
Reported: 2006-02-22 21:27 UTC by Rahul Sundaram
Modified: 2013-03-13 05:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 21:19:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 26023 None None None Never

Description Rahul Sundaram 2006-02-22 21:27:45 UTC
Description of problem:



Steps to Reproduce:
1. Remove a package using pirut
2. End of removal it says "Software installation completed"

  
Actual results:

Software installation completed

Expected results:

Software removal completed

Additional info:

Seems to take a long time to check for dependencies while removing packages and
intermediate time between checking for dependencies and the transaction message,
pirut seems to hang

Comment 1 Jeremy Katz 2006-02-22 23:39:42 UTC
All of the messages tend to say installation generically.  I'm up for better
ways to phrase it, especially given the fact that adding and removing are
possible in the same transaction

Comment 2 Rahul Sundaram 2006-03-06 10:14:51 UTC

Perhaps it should say "Software transaction completed" instead. CC'ing quaid for
better word smithing...


Comment 3 Karsten Wade 2006-03-06 13:03:19 UTC
"Software operation completed" is the best alternative I can dig up.  However,
it is not as accurate as 'transaction'.  

Rahul, do you think 'transaction' translates well enough?  Our usage seems a
little idiomatic to me, or rather, focused on the truth under the covers.  The
user may not see it as a transaction, even though pirut is actually transacting
with a software repo.

Without anything better, 'transaction' is the clearest and most accurate, IMO.

Comment 4 Rahul Sundaram 2006-03-06 13:10:32 UTC
I agree with that. Transcation is technically accurate but doesnt really
translate well at all. We need to get over the urge to communicate the
underlying technological details and just present the message in the best way
that makes sense for the general non technical end user (ie) directory vs folder
analogy. 

Software operation completed might be a better option though its kind of vague.
It just might be better to code in and differentiate a software removal from a
software installation and be more clear if that isnt too much trouble. 





Comment 5 Jeremy Katz 2006-03-06 16:42:57 UTC
The problem with doing just a check and doing installation and removal as
separate messages is that it still doesn't solve the case where a user adds and
removes software in the same transaction.

I'll think about operation a bit and if I have to rebuild pirut, I'll change it,
but at this point, it's not worthy of changing just for this :)

Comment 6 Jeremy Katz 2006-08-07 15:17:29 UTC
*** Bug 201416 has been marked as a duplicate of this bug. ***

Comment 7 IBM Bug Proxy 2006-08-15 23:12:34 UTC
Sorry, I hadn't looked in Fedora Core for this problem - I've set up mirroring
to this bug, instead.

Comment 8 Jeremy Katz 2006-09-11 21:19:00 UTC
Fixed in CVS

Comment 9 IBM Bug Proxy 2006-09-14 10:30:51 UTC
----- Additional Comments From liuyan@cn.ibm.com  2006-09-14 06:25 EDT -------
Hit bug 26878 while trying this bug in beta 1. 

Comment 10 IBM Bug Proxy 2006-10-26 19:01:05 UTC
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |CLOSED
             Impact|------                      |Functionality




------- Additional Comments From yongwenw@us.ibm.com  2006-10-26 14:58 EDT -------
Fixed in beta1 milestone5. Close. 


Note You need to log in before you can comment on or make changes to this bug.