Bug 182497 - bash globbing bug in ranges (e.g. [a-z])
bash globbing bug in ranges (e.g. [a-z])
Status: CLOSED DUPLICATE of bug 77349
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 16:38 EST by dan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 18:01:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dan 2006-02-22 16:38:48 EST
Description of problem:
In bash, ranges such as [a-z] do not work correctly:

Example:

$ls
a A b B c C d D e E f F

$ls [abc]*
a b c

$ls [a-c]*
a A b B c

 - note: both capitals and lower case show up, except the final capital in the
range (no file "C").

Version-Release number of selected component (if applicable):
3.0

How reproducible: always


Steps to Reproduce: follow example above
1.
2.
3.
  
Actual results: see above


Expected results: 
$ls [a-c]*
a b c

$ls [A-C]*
A B C


Additional info:
Comment 1 Tim Waugh 2006-02-22 18:01:25 EST
You need to set 'LC_COLLATE=C' in the environment if that's the behaviour you
need.  Closing as a duplicate of, for exampe, bug #77349 (but there are many
other examples).

*** This bug has been marked as a duplicate of 77349 ***

Note You need to log in before you can comment on or make changes to this bug.