Bug 18250 - Upgrade from 6.2 fails
Upgrade from 6.2 fails
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 14:01 EDT by amitabha
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 15:26:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description amitabha 2000-10-03 14:01:26 EDT
No problems during the actual upgrade on an AMD Athlon system from 6.2
to 7.0.  But would never boot. I could not see all the error messages
but the gist of events is as follows:

it would say that /dev/hda5 (where Linux is installed) has some errors -
a free inode and drop root into a shell to run fsck manually.
 On exiting, the machine would boot again and then hang on
what it says are wrong file permissions for several system files.
(for example, wrong  file permissions for /etc/.... , can't recall the name
exactly, should be 4/7 etc....)
Comment 1 Michael Fulbright 2000-10-03 14:36:40 EDT
Moving to anaconda component (the name of the installer)
Comment 2 Michael Fulbright 2000-10-03 14:37:24 EDT
Can you think of any way to reproduce this?   Its going to be hard to resolve
unless we can reproduce the
bug.
Comment 3 amitabha 2000-10-03 15:01:01 EDT
I don't know of a way to reproduce this except doing the installation again
and somehow keeping a log of ALL error messages.  I would be happy to do that.


However can you tell me whether I can do the installation/upgrade without
ruining my 6.2 installation which I am happy with ? 

 If it never boots up, how can I get access to the log files ?  

 I should mention that  this problem appears after it loads kernel parameters, 
starts the USB controller, finding module dependencies etc Then it runs
Kudzu and detects VIA sound card. I tried both ignoring it in the hardware
configuration and configuring it, but that does not seem to make a difference
to the subsequent hangup.  By the way, 6.2 never got my VIA card working. 

  I used the kernel parameter x86_serial_nr=1 when upgrading the kernel
because the AMD Athlon family of chips seems to need this for Linux
to work.  


 If it is possible to do a non destructive install with debug mode (and access
to the error messages) please let me know. 
Comment 4 Michael Fulbright 2000-10-03 15:26:43 EDT
There isn't a good way to do this unfortunately.

We've had people here upgrade with Athlon systems ok.

I am going to mark this 'WORKSFORME' but personally bookmark it so if I see more
bugs like this I can reopen it quickly.

Thanks for the report.

Comment 5 Need Real Name 2001-06-27 00:47:57 EDT
Similar problems upgrading an AMD K6-2 system from 6.2 to 7.0.  The system fails at the time it goes to mount the file system. Attempts at upgrade
fail with error message indicating that the files system integrity is compromised from an incomplete shutdown. There is no way to reboot, remount the 
file system and do an orderly shutdown. I'm screwed without doing a full install!!!!

Note You need to log in before you can comment on or make changes to this bug.