Bug 1825007 - Tuned profile is not updated after incorrect tuned CR is fixed
Summary: Tuned profile is not updated after incorrect tuned CR is fixed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Tuning Operator
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: jmencak
QA Contact: Simon
URL:
Whiteboard:
Depends On: 1824473
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-16 20:06 UTC by jmencak
Modified: 2020-05-11 21:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The Node Tuning Operator does not ship with the fixes to address tuned daemon behaviour for 1774645 and 1702724. Consequence: When an invalid profile is specified by the user, this results in a DoS of the operand's (tuned daemon) functionality and a correction of that profile does not restore the operand's functionality. Fix: Apply fixes for 1774645 and 1702724 to the tuned daemon. Result: Tuned daemon will correctly process and set set the new, corrected profile.
Clone Of: 1824473
Environment:
Last Closed: 2020-05-11 21:20:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-tuned pull 38 None closed Bug 1825007: Fix tuned reload behaviour on SIGHUP for invalid tuned profiles. 2020-06-23 15:29:13 UTC
Red Hat Product Errata RHBA-2020:2006 None None None 2020-05-11 21:20:51 UTC

Description jmencak 2020-04-16 20:06:23 UTC
+++ This bug was initially created as a clone of Bug #1824473 +++

+++ This bug was initially created as a clone of Bug #1823941 +++

Description of problem:

 When tuned CR is created containing an error, fixing the the mistake in the CR does not update the tuned profile on the host. The tuned pod has to be manually restarted for the changes to take effect. 


Version-Release number of selected component (if applicable):
4.3

How reproducible:
100%

Steps to Reproduce:
1. # oc lable node NODE1 tuned=test

2. Create tuned CR with error the value kernel.pid_max=1048575 is set 2x. 

apiVersion: tuned.openshift.io/v1
kind: Tuned
metadata:
  name: ips
  namespace: openshift-cluster-node-tuning-operator
spec:
  profile:
  - data: |
      [main]
      summary=A custom OpenShift IPS host profile
      [sysctl]
      kernel.msgmni=4096
      kernel.pid_max=1048575
      kernel.shmmax=180000000
      kernel.sem="128 1048576 32 32768"
      net.core.rmem_default=>33554431
      net.core.rmem_max=>33554431
      fs.file-max=>240000
      vm.dirty_background_ratio=64
      vm.dirty_ratio=72
      kernel.pid_max=1048575
    name: ips-host
  recommend:
  - match:
    - label: tuned
      value: ips
    priority: 20
    profile: ips-host


3. fix the tuned CR or delete and replace with fixed removing the duplicate kernel.pid_max

# oc delete tuned ips
# oc create -f fixed-ips.yaml 


Actual results:
Nothing 

Expected results:
Tuned profile to get updated 


Additional info:

In order for this to take effect the tuned pod has to be restarted manually

--- Additional comment from Ryan Howe on 2020-04-14 20:11:35 UTC ---

Typo in my steps 

# oc lable node NODE1 tuned=ips 


THe issue is still present I just typed up the steps wrong.

--- Additional comment from  on 2020-04-16 07:22:31 UTC ---

Upstream fix for 4.5: https://github.com/openshift/cluster-node-tuning-operator/pull/123

--- Additional comment from  on 2020-04-16 09:51:28 UTC ---

Upstream PR for 4.4: https://github.com/openshift/cluster-node-tuning-operator/pull/125

Comment 1 jmencak 2020-04-16 20:10:20 UTC
Upstream PR for 4.3: https://github.com/openshift/openshift-tuned/pull/38

Comment 4 Simon 2020-04-27 19:27:17 UTC
Pass!

Cluster version:

4.3.0-0.nightly-2020-04-27-081123

Comment 6 errata-xmlrpc 2020-05-11 21:20:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2006


Note You need to log in before you can comment on or make changes to this bug.