Bug 1825029 - Prometheus is not reporting router metrics
Summary: Prometheus is not reporting router metrics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ibm-roks-toolkit
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Cesar Wong
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks: 1843284 1843285
TreeView+ depends on / blocked
 
Reported: 2020-04-16 21:17 UTC by Cesar Wong
Modified: 2020-10-27 15:58 UTC (History)
0 users

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:57:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ibm-roks-toolkit pull 25 0 None closed Bug 1825029: Add monitoring label to ingress namespace 2020-09-14 11:43:34 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:58:06 UTC

Description Cesar Wong 2020-04-16 21:17:31 UTC
Description of problem:
Router metrics are not getting scraped by Prometheus

How reproducible:
Always

Steps to Reproduce:
1. Run openshift e2e conformance against an IBM ROKS cluster

Actual results:
The following tests fail:
[Feature:Prometheus][Conformance] Prometheus when installed on the cluster should provide ingress metrics`,
[Conformance][Area:Networking][Feature:Router] The HAProxy router should enable openshift-monitoring to pull metrics`,


Expected results:
No tests fail

Additional info:

Comment 1 Cesar Wong 2020-06-02 21:58:15 UTC
This is happening because the openshift-ingress namespace is missing the "openshift.io/cluster-monitoring: true" label.
We should be able to add this in the ibm-roks-toolkit code.

Comment 4 Cesar Wong 2020-06-09 16:42:38 UTC
Moving to verified - (no release associated, as this is a bug in the ibm-roks-toolkit)

Comment 6 errata-xmlrpc 2020-10-27 15:57:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.