Bug 1825109 - marketplace.openshift.io/action-text annotation doesn't take effect
Summary: marketplace.openshift.io/action-text annotation doesn't take effect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-17 06:06 UTC by Yadan Pei
Modified: 2020-07-13 17:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:28:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
Tigera Operator no Install button (248.67 KB, image/png)
2020-04-20 02:59 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5095 0 None closed Bug 1825109: Fix action text annotation name 2021-01-22 16:44:08 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:28:54 UTC

Description Yadan Pei 2020-04-17 06:06:58 UTC
Description of problem:
add marketplace.openshift.io/action-text annotation for some operator, in operator details modal, the button text is still 'Purchase' 

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-16-183237

How reproducible:
Always

Steps to Reproduce:
1. create a customized operator with marketplace.openshift.io/remote-workflow, marketplace.openshift.io/action-text, marketplace.openshift.io/support-workflow annotation
# cat 0.2.0/akka-cluster-operator.v0.2.0.clusterserviceversion.yaml 
apiVersion: operators.coreos.com/v1alpha1
kind: ClusterServiceVersion
metadata:
  name: akka-cluster-operator.v0.2.0
  namespace: placeholder
  annotations:
    capabilities: Seamless Upgrades
    categories: Application Runtime
    marketplace.openshift.io/remote-workflow: https://marketplace.redhat.com/foo
    marketplace.openshift.io/action-text: 'Request Quota'
    marketplace.openshift.io/support-workflow: 'https://marketplace.redhat.com/foo'
# cat yapei-custom-catalog-source.yaml 
apiVersion: operators.coreos.com/v1alpha1
kind: CatalogSource
metadata:
  name: yapei-custom-catalogsource
  namespace: openshift-marketplace
spec:
  sourceType: grpc
  image: quay.io/yapei/akka-operator:annotation
  displayName: Customized Catalog Source YAPEI
  publisher: yapei
# oc create -f yapei-custom-catalog-source.yaml
2. wait syncing pods is ready
# oc get pods -n openshift-marketplace | grep yapei
yapei-custom-catalogsource-v6hpf        1/1     Running   0          3h14m
3. check operator details at Operators -> OperatorHub -> click on Provider Type: Customized Catalog Source YAPEI -> click on Aka Cluster Operator

Actual results:
3. We can see 'Get support' link and 'Purchase' button link are pointing to the link "https://marketplace.redhat.com/foo" we added in CSV annotation, but the button text is still 'Purchase' 


Expected results:
3. according to https://issues.redhat.com/projects/CONSOLE/issues/CONSOLE-1953
The button will override the current "Purchase" button with the provided "Action Text", in this case the 'Purchase' button text should be 'Request Quota'

Additional info:

Comment 4 Yadan Pei 2020-04-20 02:59:46 UTC
Created attachment 1680188 [details]
Tigera Operator no Install button

1. admin user goes to Operators -> OperatorHub -> Tigera Operator(which has marketplace.openshift.io/action-text annotation), on Operator details modal page, only `Install-time Instructions` button is shown, we didn't show 'Install' button so that user can't subscribe operator in OpenShift


This is checked on  4.5.0-0.nightly-2020-04-18-184707

Comment 5 Yadan Pei 2020-04-20 07:55:18 UTC
When there is an action text annotation, show only the button with that text/remote workflow. When there is not, show the usual install/uninstall workflow. This is intended change in console PR #5082

Moving to VERIFIED

Comment 6 errata-xmlrpc 2020-07-13 17:28:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.