Bug 182511 - Video mode is too high for the ES1000 video ASIC (RN50)
Video mode is too high for the ES1000 video ASIC (RN50)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Desktop
: 179886 180274 (view as bug list)
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-02-22 17:32 EST by Rod Macdonald
Modified: 2007-11-30 17:07 EST (History)
10 users (show)

See Also:
Fixed In Version: RHEL4 U4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-09 11:05:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch including the fix to reduce pixel clock. (4.06 KB, patch)
2006-02-22 17:37 EST, Rod Macdonald
no flags Details | Diff

  None (edit)
Description Rod Macdonald 2006-02-22 17:32:06 EST
This problem was reported by Dell and affects RHEL3 and RHEL4.

When using a monitor that can handle very large resolutions it is possible to
configure the video output beyond what the ES1000 can handle.  

Specifically we are seeing resolution 1600x1200@85Hz which will display with
corruption.  This mode is beyond what the ES1000 can support when using 16bit
memory at 200MHz.

ATI has provided a patch that uses an emperical formula to limit the pixel 
clock thereby limiting the resolutions that are available.  This is part of a 
larger RHEL4 patch which will be appended shortly.  We are still working on a 
backport to RHEL3.

This is also upstream - https://bugs.freedesktop.org/show_bug.cgi?id=5766
Comment 1 Rod Macdonald 2006-02-22 17:37:15 EST
Created attachment 125069 [details]
Patch including the fix to reduce pixel clock.
Comment 3 Mike A. Harris 2006-03-07 05:20:36 EST
Ok, I've reviewed the patch in comment #1, and it seems ok except for:

@@ -3524,7 +3526,11 @@
     /* don't use RMX if we have a dual-tmds panels */
    if (pRADEONEnt->MonType2 == MT_DFP)
 	info->ddc_mode = TRUE;
-
+   
+   if (info->IsDellServer)
+   {
+       info->ddc_mode = TRUE;
+   }
     xf86DrvMsg(pScrn->scrnIndex, X_INFO,
 	       "Validating modes on %s head ---------\n",
 	       info->IsSecondary ? "Secondary" : "Primary");



That seems to have accidentally gotten into the patch, as it has
nothing to do with fixing the reported problem as far as I can tell.

I've discussed this problem with Michel, who has described the details
to me, and provided the following upstream bug report with the current
patch attached:

https://bugs.freedesktop.org/show_bug.cgi?id=5766

Comment 4 Mike A. Harris 2006-03-07 05:33:47 EST
This is the patch that we'll probably be going with, from the above upstream bug:

https://bugs.freedesktop.org/attachment.cgi?id=4636
Comment 5 Mike A. Harris 2006-03-07 05:42:18 EST
I believe the following bug might be a dupe of this, but it was filed with
zero useful information, so hard to tell:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179886

I've requested details in that bug, and will close it as a dupe of this one
if we can conclude it is the same issue they're requesting an update for.
Comment 6 Mike A. Harris 2006-03-07 05:57:43 EST
*** Bug 180274 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2006-03-21 13:54:01 EST
*** Bug 179886 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2006-03-28 13:02:31 EST
Patch xorg-x11-6.8.2-ati-radeon-rn50-pixelclock-limit-bug182511.patch added
to test candidate for U4.

Please test the xorg-x11-6.8.2-1.EL.13.26 packages available for download via
FTP at:  ftp://people.redhat.com/mharris/testing/4E/xorg-x11
Comment 9 Rod Macdonald 2006-03-28 13:33:02 EST
Mike, can you also provide a patch for RHEL3.  Can this be a candidate for U8.
Comment 11 Rod Macdonald 2006-04-04 16:18:03 EDT
Mike, sorry for the delay.  We have tested the patch on RHEL4 U3 and it works 
correctly, limiting the modes as follows: 

For 24bpp, Max: 1280x1024@60Hz
For 16bpp, Max: 1600x1200@75Hz 
For 8bpp, Max: 1920x1440@60Hz

Can you advise when this will be available in a RHEL4 Ux beta?  Also can you 
provide a patch for RHEL3?

Comment 15 Mike A. Harris 2006-04-25 10:34:29 EDT
(In reply to comment #9)
> Mike, can you also provide a patch for RHEL3.  Can this be a candidate for U8.

Theoretically the patch could be backported to RHEL-3, probably trivially.
In order to include any fix into RHEL-3 or RHEL-4 in an update cycle
however, an official request needs to be filed against each individual
OS release that is relevant for a particular problem.  This provides us
with the ability to track every issue per-OS-release and to allocate
developer resources to issues per-OS-release.

In order to consider this for RHEL-3 at this late stage in the U8 cycle,
we need to have an issue tracker request filed by Dell or ATI against RHEL-3,
and if product management approves it through our exception process, there
may still be time to consider this for RHEL-3-U8.


Comment 16 Mike A. Harris 2006-04-25 10:39:58 EDT
(In reply to comment #11)
> Mike, sorry for the delay.  We have tested the patch on RHEL4 U3 and it works 
> correctly, limiting the modes as follows: 
> 
> For 24bpp, Max: 1280x1024@60Hz
> For 16bpp, Max: 1600x1200@75Hz 
> For 8bpp, Max: 1920x1440@60Hz

Good to hear.  Setting bug to "MODIFIED" state for QA testing.

> Can you advise when this will be available in a RHEL4 Ux beta?

It's present in build now, and will be in the RHEL4 U4 betas.  The
ATI partner manager may be able to provide the beta release schedule
to you for more specific timeframes though.

Hope this helps.
Comment 18 Rod Macdonald 2006-04-27 10:38:37 EDT
(In reply to comment #15)
> Theoretically the patch could be backported to RHEL-3, probably trivially.
> In order to include any fix into RHEL-3 or RHEL-4 in an update cycle
> however, an official request needs to be filed against each individual
> OS release

ATI has completed and tested the backport.  A separate bugzilla has now been 
opened which contains this patch for RHEL3:  
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189927

> In order to consider this for RHEL-3 at this late stage in the U8 cycle,
> we need to have an issue tracker request filed by Dell or ATI against RHEL-3

I will ask our contact at Dell to open this issue tracker as soon as 
possible.  
Comment 21 Red Hat Bugzilla 2006-07-12 12:46:03 EDT
Bug report changed to from ON_QA to VERIFIED status by Errata System.
Advisory RHBA-2006:0412-21.
http://errata.devel.redhat.com/errata/errata/showrequest.cgi?advisory=3850
The RN50 works properly.

Note You need to log in before you can comment on or make changes to this bug.