Bug 182513 - Unable to share printers without the GUI
Unable to share printers without the GUI
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-printer (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 17:47 EST by Tethys
Modified: 2008-08-19 09:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 09:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2006-02-22 17:47:19 EST
Description of problem:
The documentation[1] says to share a printer, select the printer from the
list and then choose Action->Sharing. Well, that'd be nice, but there's
no such thing. Since this is a server, X is not installed, and thus
system-config-printer brings up the text mode interface. Running the
GUI simply isn't an option, as it's not installed. The text mode appears
to be missing some of the features present in the GUI equivalent, such as
the ability to share printers.

[1]
http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/sysadmin-guide/s1-printing-sharing.html

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116.4-1


How reproducible:
Every time

Steps to Reproduce:
1. printconf (if you have X installed, you'll need to run printconf-tui)
2. select printer to share
3. now what?
  

Additional info:

I'm able to get *some* things partially working by manually editing the
/etc/cups/cupsd.conf file to tell it to listen on more than just 127.0.0.1,
and to accept connections from my LAN range. But I'm nervous because it
says not edit it, as it's automatically generated. Is it talking about
system-config-printer here, or something else? Will I lose everything
when I add a new printer? How am I *meant* to be doing this?
Comment 1 Tim Waugh 2006-02-23 04:37:31 EST
The text-mode interface never had this functionality added.

As a work-around you can export the configuration data to an XML file:

printconf-tui --Xexport > conf.xml

Then move the conf.xml file to a spare X-capable machine.  On that machine, make
a back-up of *its* data and import the data from the X-less machine:

printconf-tui --Xexport > backup.xml
printconf-tui --Ximport < conf.xml

The edit that data as you like, using the graphical tool:

printconf-gui

When you have finished and clicked 'Apply', export and restore:

printconf-tui --Xexport > conf.xml
printconf-tui --Ximport < backup.xml
/sbin/service cups restart # this is the equivalent of 'Apply'

Move the conf.xml file back to the X-less machine and import the new data:

printconf-tui --Ximport < conf.xml
/sbin/service cups restart
Comment 2 Phil Knirsch 2008-08-19 09:10:26 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.