Bug 182518 - Failure to boot on iMac G5 with iSight
Failure to boot on iMac G5 with iSight
Status: CLOSED DUPLICATE of bug 182180
Product: Fedora
Classification: Fedora
Component: yaboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
http://fluffnet.serveftp.com/~kyle/oh...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 18:21 EST by Kyle Pointer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 15:15:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle Pointer 2006-02-22 18:21:28 EST
Description of problem:
I have the latest FC4 test4 rescue image. 
1) I put it in, and held down the option key
2) I chose to boot from the CD.
3) I get the ugly error in the video I linked too for the URL.

http://fluffnet.serveftp.com/~kyle/ohno.mp4
[ I assume you can play that with VLC or Mplayer or Xine or something... ]

How reproducible:
every time I try to boot

I'm not sure if this is a yaboot problem or not, but it's happening before the installer loads. 
The movie might be really helpful.
Comment 1 Paul Nasrat 2006-02-22 18:37:48 EST
I cannot play that. Please consider theora or actually documenting the error in
the bug report.

Also please try with tomorrow's rawhide boot.iso.
Comment 2 Kyle Pointer 2006-02-22 18:48:27 EST
ok.. Well, I boot from the CD. I choose the Linux kernel. It starts to boot. Then it drops me back into the 
thing that lets me choose to boot from the hard disk or CD, but the colors are inverted. I can pretty much 
do that over and over again with new colors every time! :-D

But yeah.. it still won't boot Linux. 

I'm sure it's some sort of weird issue with the G5 iMac with iSight. 
Comment 3 Paul Nasrat 2006-02-22 19:16:41 EST
Can you try tomorrows rawhide, we were hitting an issue on a G5 here that may be
similar.

Alternately we should be able to see if you are seeing the same bug if you boot
into Open Firmware (Cmd + Option + O + F) then

boot cd:,\\:tbxi
hit return at the yaboot boot prompt
if it is the same bug I'd expect to see the screen flash white, hang for a bit
and go back to the OF 0> ok prompt.  When it does that try

.registers
dev /chosen
.properties

and report if linux,stdout-package exists and what it is set to.  I hope
tomorrows rawhide will fix this.
Comment 4 Kyle Pointer 2006-02-22 20:31:31 EST
Looks like that might be my issue! Yay!
linux,stdout-package ffffffff
linux,stdout-path 00
linux,initrd-start 00000000 01c00000
linux,initrd-end 0000000 021bd543
linux,platform 00000400

:-)
Comment 5 Kyle Pointer 2006-02-23 21:31:38 EST
Hmm... :-(
I downloaded the boot.iso from the images/ directory in the development/ directory. 
I tried to boot it, and got the white screen for a little bit longer, then it did it again. I got a new error 
though.. [ I think ]

Decrementer exception at %SRR0: 00000000.056106dc %SRR1: 10000000.00003030

[ followed by normal openfirmware stuff... ]

I might be off by a zero or two.

Comment 6 Paul Nasrat 2006-02-28 15:15:16 EST

*** This bug has been marked as a duplicate of 182180 ***

Note You need to log in before you can comment on or make changes to this bug.