Bug 182522 - crash with i2o
crash with i2o
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-22 19:15 EST by Glen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 14:47:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen 2006-02-22 19:15:37 EST
Description of problem:
I throw in the install cd, load it up, wait a little bit, and this pops up:

Starting graphical installation
Traceback (most recent calls last)
  File "/usr/bin/anaconda", line 1113, in ?
    iutil.makeDriveDeviceNodes()
  File "/usr/lib/anaconda/iutil.py", line 445, in makeDriveDeviceNodes
    isys.makeDevInode(drive, "/dev/%s" % (drive,)
  File "/usr/lib/anaconda/isys.py", line 415, in makeDevInode
    _isys.mkdevinode(name, fn)
System Error: (2, 'No such file or directory')
install exited abnormally

It's just a guess, but it might have something to do with my mandriva install
confusing the installer.  Mandriva is on one of the my two hard drives, with a
small /boot partition at the beginning, and a large lvm2 partition with two
logical volumes inside, one for root and one for swap.  My second hard drive is
completely empty.  Nothing changes if I zero out the second hard drive or
partition it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot the install cd
2.
3.
  
Actual results:
The installer crashes

Expected results:
A working installer

Additional info: I still need to load the i2o driver before my hard disk is
detected, which is rather annoying.
Comment 1 Chris Lumens 2006-02-23 09:52:08 EST
Please attach the complete exception details.
Comment 2 Glen 2006-02-24 11:33:23 EST
Say what?  That's as complete as it gets.  That's all that gets printed out to
the screen anyhow.  Is there something I can do to get more details?

Anyhow, I pulled my zero channel RAID card and tried again and now things work
fine.  So it isn't the Mandriva partitions.  Looks like i2o drivers are once
again the bane of my existance.
Comment 3 Jeremy Katz 2006-02-28 14:47:30 EST
Fixed in CVS.  i2o makes my eyes bleed.

Note You need to log in before you can comment on or make changes to this bug.