Bug 1825247 - U-Boot 2020.4 (and earlier) do not support Wandboard IMX6Q-BW RevD1
Summary: U-Boot 2020.4 (and earlier) do not support Wandboard IMX6Q-BW RevD1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: uboot-tools
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F32FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-04-17 13:27 UTC by Derek Atkins
Modified: 2020-04-23 18:02 UTC (History)
10 users (show)

Fixed In Version: uboot-tools-2020.04-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-23 18:02:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Derek Atkins 2020-04-17 13:27:08 UTC
Description of problem:

I have a RevD1 Wandboard Quad but U-Boot does not properly detect it, even in current F32-Beta with U-Boot 2020.4.  The error is shown below but is mis-detects the board as a Rev B1 (the default) and as a result uses the wrong DTB and fails to properly turn on the Ethernet.

Version-Release number of selected component (if applicable):
uboot-images-armv7-2020.04-1.fc32.noarch.rpm

How reproducible:
100% if you have the right wandboard device

Steps to Reproduce:
1. Try to install F31 or F32-Beta Fedora-Minimal
2. Run on a WB-IMX6Q-BW D1
3. Watch the serial console

Actual results:

CPU:   Freescale i.MX6Q rev1.3 at 792 MHz
Reset cause: POR
DRAM:  2 GiB
PMIC:  pmic_get() ret -19
MMC:   FSL_SDHC: 2, FSL_SDHC: 1, FSL_SDHC: 0
Loading Environment from MMC... OK
No panel detected: default to HDMI
Display: HDMI (1024x768)
In:    serial
Out:   serial
Err:   serial
Model: Wandboard i.MX6 Quad Board rev B1
Board: Wandboard rev B1
Net:   Board Net Initialization Failed


Expected results:

CPU:   Freescale i.MX6Q rev1.3 at 792 MHz
Reset cause: POR
DRAM:  2 GiB
PMIC:  PFUZE100 ID=0x10                                                         
MMC:   FSL_SDHC: 2, FSL_SDHC: 1, FSL_SDHC: 0                                    
Loading Environment from MMC... OK                                              
No panel detected: default to HDMI                                              
Display: HDMI (1024x768)                                                        
In:    serial                                                                   
Out:   serial                                                                   
Err:   serial                                                                   
Board: Wandboard rev D1                                                         
Net:                                                                            
Warning: ethernet@2188000 using MAC address from ROM                            
eth0: ethernet@2188000                                                          


Additional info:

There is a patch-set currently being discussed on the u-boot list to fix this problem.

Comment 1 Peter Robinson 2020-04-20 22:38:59 UTC
Patches were accepted upstream so I'm pulled them in and uboot-tools-2020.04-2.fc32 is building now.

Comment 2 Fedora Update System 2020-04-21 07:06:47 UTC
FEDORA-2020-e0ad98f651 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-e0ad98f651

Comment 3 Fedora Blocker Bugs Application 2020-04-21 07:08:39 UTC
Proposed as a Freeze Exception for 32-final by Fedora user pbrobinson using the blocker tracking app because:

 Wandboard is a widely used device so having it working out of the box makes it easier to support

Comment 4 František Zatloukal 2020-04-21 16:26:04 UTC
+1 FE

Comment 5 Adam Williamson 2020-04-21 18:00:12 UTC
sure, +1 FE.

Comment 6 Fedora Update System 2020-04-21 18:43:25 UTC
FEDORA-2020-e0ad98f651 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-e0ad98f651`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e0ad98f651

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Mohan Boddu 2020-04-21 18:59:35 UTC
Since we need to run another RC, +1 FE

Comment 8 Ben Cotton 2020-04-21 19:09:02 UTC
+1 FE, that seems like enough to accept. Marking as such.

Comment 9 Fedora Update System 2020-04-23 18:02:43 UTC
FEDORA-2020-e0ad98f651 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.