Bug 1825298 - Laptop not shutting down properly until force shut it off.
Summary: Laptop not shutting down properly until force shut it off.
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-17 15:38 UTC by Mohan Boddu
Modified: 2020-05-14 20:55 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
journal log (128.95 KB, text/plain)
2020-04-17 15:38 UTC, Mohan Boddu
no flags Details
Reboot with kernel-5.7.0-0.rc1.20200414git8632e9b5645b.1.fc33 (156.59 KB, text/plain)
2020-04-21 21:45 UTC, Mohan Boddu
no flags Details
Reboot with 5.7.0-0.rc2.1.fc33 (100.72 KB, text/plain)
2020-04-21 21:46 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2020-04-17 15:38:32 UTC
Created attachment 1679687 [details]
journal log

1. Please describe the problem:

When I shutoff the laptop, it goes blank but the laptop is still running until I force shut it off. I am attaching the journal log but the system keeps running even after the end of the log.

FYI, I am using new dell xps with 10th Generation Intel® Core™ i7-1065G7 Processor

2. What is the Version-Release number of the kernel:
kernel-5.6.2-301.fc32
kernel-5.7.0-0.rc1.20200414git8632e9b5645b.1.fc33


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Yes, just shutdown the laptop and it still keeps running until force shut off.


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Yes


6. Are you running any modules that not shipped with directly Fedora's kernel?:
No

Comment 1 Steve 2020-04-17 16:04:06 UTC
Thank-you for your report.

The attached log is missing some information. Could you attach another log using this procedure:

1. Attempt to shutdown.
2. Wait for the hang.
3. Press the caps-lock key to see if it controls the caps-lock light.
4. Press "ctrl-alt-f2" to see if you can get to a console.
5. Press and hold the power button to power down.
6. Press the power button to restart and login.
7. After getting to a desktop, in a terminal window run:

$ journalctl --no-hostname -k -b -1 > /tmp/dmesg-1.txt

The "-b -1" option selects the log for the previous boot.

Attach /tmp/dmesg-1.txt.

Comment 2 Mohan Boddu 2020-04-21 21:44:30 UTC
(In reply to Steve from comment #1)
> Thank-you for your report.
> 
> The attached log is missing some information. Could you attach another log
> using this procedure:
> 
> 1. Attempt to shutdown.
> 2. Wait for the hang.
> 3. Press the caps-lock key to see if it controls the caps-lock light.
> 4. Press "ctrl-alt-f2" to see if you can get to a console.
> 5. Press and hold the power button to power down.
> 6. Press the power button to restart and login.
> 7. After getting to a desktop, in a terminal window run:
> 
> $ journalctl --no-hostname -k -b -1 > /tmp/dmesg-1.txt
> 
> The "-b -1" option selects the log for the previous boot.
> 
> Attach /tmp/dmesg-1.txt.

So, two things here:

Running kernel-5.7.0-0.rc1.20200414git8632e9b5645b.1.fc33 didn't do anything when I pressed caps-lock or ctrl-alt-f2, but when I pressed any key it was able to light up the backlit keyboard. I am attaching the dmesg-1.txt for this kernel.

Running 5.7.0-0.rc2.1.fc33 same thing happened as above but it *didn't* light up the backlit keyboard. I guess thats a progress, but still I need to hard shut it off. I am attaching the dmesg-2.txt for this kernel.

Comment 3 Mohan Boddu 2020-04-21 21:45:36 UTC
Created attachment 1680696 [details]
Reboot with kernel-5.7.0-0.rc1.20200414git8632e9b5645b.1.fc33

Comment 4 Mohan Boddu 2020-04-21 21:46:06 UTC
Created attachment 1680697 [details]
Reboot with 5.7.0-0.rc2.1.fc33

Comment 5 Steve 2020-04-22 02:59:52 UTC
Thanks for the additional test reports and for attaching the logs.

In dmesg-1.txt, it looks like you attempted to suspend. Does suspend work?

Could you post the output from:

$ grep -s '' /sys/power/*

Some of the log entries below are in another bug, also with a Dell XPS 13:

Bug 1812010 - Kernel 5.5.7-200 does not suspend on Dell XPS-13 

==
$ egrep -B3 'suspend|s2idle|serio1: Failed' dmesg-1.txt 
...
Apr 17 15:59:16 kernel: PM: suspend entry (s2idle) <<<<<<
--
Apr 17 17:32:56 kernel: Freezing user space processes ... (elapsed 0.259 seconds) done.
Apr 17 17:32:56 kernel: OOM killer disabled.
Apr 17 17:32:56 kernel: Freezing remaining freezable tasks ... (elapsed 0.003 seconds) done.
Apr 17 17:32:56 kernel: printk: Suspending console(s) (use no_console_suspend to debug)
Apr 17 17:32:56 kernel: wlp0s20f3: deauthenticating from 14:dd:a9:8d:26:64 by local choice (Reason: 3=DEAUTH_LEAVING)
Apr 17 17:32:56 kernel: psmouse serio1: Failed to disable mouse on isa0060/serio1 <<<<<<
Apr 17 17:32:56 kernel: PM: suspend devices took 2.121 seconds
--
Apr 17 17:32:56 kernel: Restarting tasks ... 
Apr 17 17:32:56 kernel: mei_hdcp 0000:00:16.0-b638ab7e-94e2-4ea2-a552-d1c54b627f04: bound 0000:00:02.0 (ops i915_hdcp_component_ops [i915])
Apr 17 17:32:56 kernel: done.
Apr 17 17:32:56 kernel: PM: suspend exit

Comment 6 Steve 2020-04-22 03:00:40 UTC
For the record:

$ grep DMI: dmesg-1.txt 
Apr 17 15:50:53 kernel: DMI: Dell Inc. XPS 13 9300/0WX9VX, BIOS 1.0.6 01/17/2020

Comment 7 Steve 2020-04-22 03:09:17 UTC
This may not be related to the shutdown hang, but there are some errors related to wireless firmware. How is your wireless working?

$ fgrep -A17 'Intel(R) Wireless WiFi driver for Linux' dmesg-1.txt 
Apr 17 15:52:57 kernel: Intel(R) Wireless WiFi driver for Linux
Apr 17 15:52:57 kernel: Copyright(c) 2003- 2015 Intel Corporation
Apr 17 15:52:57 kernel: iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-Qu-c0-hr-b0-53.ucode failed with error -2 <<<<<<
...
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version: 43.2.23.17
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: Found debug destination: EXTERNAL_DRAM
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: Found debug configuration: 0
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: loaded firmware version 48.4fa0041f.0 Qu-c0-hr-b0-48.ucode op_mode iwlmvm
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwl-debug-yoyo.bin failed with error -2 <<<<<<
Apr 17 15:52:58 kernel: thunderbolt 0000:00:0d.2: 0: uid crc8 mismatch (expected: 0x0, got: 0xfe)
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: Detected Killer(R) Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter (201NGW), REV=0x338
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: Allocated 0x00400000 bytes for firmware monitor.
Apr 17 15:52:58 kernel: iwlwifi 0000:00:14.3: base HW address: 54:8d:5a:75:b4:d0

Comment 8 Marc C 2020-05-09 17:02:22 UTC
Hi Steve,

I just figured I would chime in with a "me too", and offer to help with any providing data from another laptop with the same issue.

Just to recap, at the moment a reboot or shutdown won't fully complete.  Systemctl finishes properly without any errors, then the laptop just doesn't turn off (or reset).  Black screen, keyboard backlight will respond when touched.  Press and hold power for >8 seconds and the machine is forced off.  It's like Linux can't get the laptop to reset or power off!


And to ask about WiFi?  It wasn't working, but that's been fixed as of newer 5.6 kernels, per bug #1788150 that I have been watching closely.  Up until that point, I was using a firmware for an alternate card from the Chromium project, but now I'm using what comes with Fedora.

I'm still on FC31.  Kernel 5.6.8-200, Dell BIOS 1.0.7 (latest).  I've found so much history with Dell Laptops and workstations not behaving properly at shutdown/reboot that I've taken to messing with the ACPI params in the kernel command line.  No such luck.  Sadly, I didn't document all the things I tried.  At the moment I'm booting with "acpi_rev_override=1" with no improvement.

This may be my first post, but I'm a long-time Linux user and administrator, I can get this ticket what it needs.  I was thinking about jumping to FC32 this weekend or a day next week, so I can catch up to the latest Fedora if you're looking to hit me up for more logs and tests.

Comment 9 Steve 2020-05-10 17:57:44 UTC
(In reply to Marc C from comment #8)

Thanks for your report. Could you open a new bug report? That makes it easier to see how many people are having a certain problem, and it makes it easier to keep track of attachments.

If a problem appears to be the same in several cases, some of the bug reports can be closed as duplicates.*

Please select "kernel" for the component.

I suggest a bug summary something like this:

"Dell [model number] hangs with black screen on shutdown or reboot"

Your second paragraph is a good description of the problem, so you can just copy it and paste it into the new bug report.

* https://bugzilla.redhat.com/page.cgi?id=fields.html#resolution

Comment 10 Steve 2020-05-14 20:55:58 UTC
Mohan: Marc may have found a workaround for the shutdown problem you reported:

'Go into the BIOS of the laptop, under Virtualization, and DISABLE the option "VT for Direct I/O".'

That's from this upstream bug report:

Bug_206571 - [Bisected] On kernel 5.5 system hangs on shutdown or reboot 
https://bugzilla.kernel.org/show_bug.cgi?id=206571

Related downstream bug report:

Bug 1834277 - Dell XPS 13 9300 (2020) hangs with black screen on shutdown or reboot and 5.7.0-0.rc4


Note You need to log in before you can comment on or make changes to this bug.