Bug 1825330 - Potential for data loss converting from v1beta1 to v1 CRDs
Summary: Potential for data loss converting from v1beta1 to v1 CRDs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.5.0
Assignee: Daniel Sover
QA Contact: Bruno Andrade
URL:
Whiteboard:
: 1826024 1828172 1828677 1828891 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-17 17:48 UTC by Daniel Sover
Modified: 2020-07-13 17:28 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:28:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1470 0 None closed Bug 1825330: support creating v1beta CRDs to avoid data loss 2020-11-11 07:44:40 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:28:58 UTC

Comment 2 Anik 2020-04-23 15:54:01 UTC
*** Bug 1826024 has been marked as a duplicate of this bug. ***

Comment 4 Ben Luddy 2020-04-27 18:25:09 UTC
*** Bug 1828172 has been marked as a duplicate of this bug. ***

Comment 5 Ben Luddy 2020-04-28 16:18:14 UTC
*** Bug 1828677 has been marked as a duplicate of this bug. ***

Comment 9 umanga 2020-04-29 15:05:36 UTC
*** Bug 1828891 has been marked as a duplicate of this bug. ***

Comment 10 Martin Bukatovic 2020-04-29 16:22:35 UTC
Setting OCS as a dependent product, because this BZ was marked as a duplicate of OCS BZ 1828891.

Comment 11 Lukas Bednar 2020-04-30 13:48:53 UTC
Could you please let me know what build should contain a fix?

I am trying 4.5.0-0.nightly-2020-04-30-034256 , and I am still seeing following:

no matches for kind "CatalogSourceConfig" in version "operators.coreos.com/v1"

Comment 14 Bruno Andrade 2020-04-30 18:22:24 UTC
Installed istio-operator.v1.1.0 which fails due to this issue( https://raw.githubusercontent.com/Maistra/istio-operator/maistra-1.1/manifests-maistra/1.1.0/servicemeshcontrolplanes.crd.yaml) through OperatorHub and works as expected.

oc get csv -n openshift-operators
NAME                     DISPLAY                VERSION   REPLACES   PHASE
maistraoperator.v1.1.0   Maistra Service Mesh   1.1.0                Succeeded


oc get ServiceMeshControlPlane -n openshift-operators
NAME            READY   STATUS           TEMPLATE   VERSION   AGE
basic-install           Running          default    v1.1      11m


Cluster Version: 4.5.0-0.nightly-2020-04-30-084834

Marking as VERIFIED.

Comment 15 errata-xmlrpc 2020-07-13 17:28:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.