Bug 1825339 - [4.4.z] Kuryr-cni restarts during conformance tests due to namespace not found
Summary: [4.4.z] Kuryr-cni restarts during conformance tests due to namespace not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Peter Hunt
QA Contact: MinLi
URL:
Whiteboard:
Depends On: 1820118
Blocks: 1838116 1851903
TreeView+ depends on / blocked
 
Reported: 2020-04-17 18:22 UTC by Peter Hunt
Modified: 2020-07-21 10:31 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1820118
Environment:
Last Closed: 2020-07-21 10:31:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1871 None closed Bug 1825339: [4.4] crio: manage ns lifecycle 2020-08-10 20:16:58 UTC
Red Hat Product Errata RHBA-2020:2913 None None None 2020-07-21 10:31:46 UTC

Comment 4 Peter Hunt 2020-07-06 13:53:57 UTC

*** This bug has been marked as a duplicate of bug 1851903 ***

Comment 5 Peter Hunt 2020-07-06 13:55:16 UTC
that was a mistake

Comment 8 MinLi 2020-07-16 09:15:55 UTC
verified on version : 4.4.0-0.nightly-2020-07-14-173909

I verified that cri-o is now managing namespace lifecycle in https://bugzilla.redhat.com/show_bug.cgi?id=1831866#c3
And Kuryr can now correctly mount namespace  https://bugzilla.redhat.com/show_bug.cgi?id=1831112#c4

Comment 10 errata-xmlrpc 2020-07-21 10:31:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2913


Note You need to log in before you can comment on or make changes to this bug.