Bug 1825418 - oVirt prompts and logging aren't correctly formatted
Summary: oVirt prompts and logging aren't correctly formatted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Wei Sun
QA Contact: Jan Zmeskal
URL:
Whiteboard:
: 1814713 (view as bug list)
Depends On: 1825415
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-17 23:27 UTC by Alex Crawford
Modified: 2020-05-04 11:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1825415
Environment:
Last Closed: 2020-05-04 11:49:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3475 None closed Bug 1825418: pkg/destroy/ovirt: Cleanup VM logging 2020-05-11 12:55:41 UTC
Github openshift installer pull 3480 None closed Bug 1825418: ovirt: clean up prompts and logging 2020-05-11 12:55:41 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:49:45 UTC

Description Alex Crawford 2020-04-17 23:27:22 UTC
+++ This bug was initially created as a clone of Bug #1825415 +++

For example:

$ openshift-install destroy cluster --dir one
INFO searching VMs by tag=one-6xlb7
INFO Found %!s(int=3) VMs
INFO Stopping VM one-6xlb7-master-1 : errors: %s%!(EXTRA <nil>)
INFO Stopping VM one-6xlb7-master-2 : errors: %s%!(EXTRA <nil>)
INFO Stopping VM one-6xlb7-master-0 : errors: %s%!(EXTRA <nil>)
INFO Removing VM one-6xlb7-master-1 : errors: %s%!(EXTRA <nil>)


I'm marking this high because of the impact it has on the user experience.

Comment 1 Wei Sun 2020-04-20 08:11:56 UTC
PR 3480 has been merged, PR 3475 was closed. Move this bug to MODIFIED.

Comment 4 Jan Zmeskal 2020-04-21 11:26:44 UTC
Verification steps:
1. Run openshift-isntall create install-config --dir=test-cluster --log-level=debug
2. Going through the options, trying to display help for each one of them

Verified with:
openshift-install version
./openshift-install 4.4.0-0.nightly-2020-04-21-033933
built from commit 2faa8d77b4d8baac4963b81f39132a11092920d7
release image quay.io/openshift-release-dev/ocp-release-nightly@sha256:be4b1e3f3e1e240f578d67c0e7e91085f1308dd8a0cd0f2665a20bea818b4679

Second part of verification:
1. Run openshift-install destroy cluster --dir=test-cluster --log-level=debug
Output:
DEBUG OpenShift Installer 4.4.0-0.nightly-2020-04-21-033933 
DEBUG Built from commit 2faa8d77b4d8baac4963b81f39132a11092920d7 
DEBUG Searching VMs by tag=secondary-xgbq9         
DEBUG Found 6 VMs                                  
INFO Stopping VM secondary-xgbq9-worker-0-hw22t   
INFO Stopping VM secondary-xgbq9-master-2         
INFO Stopping VM secondary-xgbq9-worker-0-spwkj   
INFO Stopping VM secondary-xgbq9-master-1         
INFO Stopping VM secondary-xgbq9-master-0         
INFO VM secondary-xgbq9-master-2 powered off      
INFO Removing VM secondary-xgbq9-master-2         
INFO Stopping VM secondary-xgbq9-worker-0-lcrzj   
INFO VM secondary-xgbq9-worker-0-spwkj powered off 
INFO Removing VM secondary-xgbq9-worker-0-spwkj   
INFO VM secondary-xgbq9-master-1 powered off      
INFO Removing VM secondary-xgbq9-master-1         
INFO VM secondary-xgbq9-worker-0-hw22t powered off 
INFO Removing VM secondary-xgbq9-worker-0-hw22t   
INFO VM secondary-xgbq9-master-0 powered off      
INFO Removing VM secondary-xgbq9-master-0         
INFO VM secondary-xgbq9-worker-0-lcrzj powered off 
INFO Removing VM secondary-xgbq9-worker-0-lcrzj   
INFO Removing tag secondary-xgbq9                 
DEBUG Purging asset "Terraform Variables" from disk 
DEBUG Purging asset "Kubeconfig Admin Client" from disk 
DEBUG Purging asset "Kubeadmin Password" from disk 
DEBUG Purging asset "Certificate (journal-gatewayd)" from disk 
DEBUG Purging asset "Metadata" from disk           
DEBUG Purging asset "Cluster" from disk

Comment 5 Jan Zmeskal 2020-04-21 11:29:35 UTC
*** Bug 1814713 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2020-05-04 11:49:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.