Bug 1825667 - LIbvirt: OCP Bootstrap on s390x fails with etcd static pods dying with UNSUPPORTED_ARCH error
Summary: LIbvirt: OCP Bootstrap on s390x fails with etcd static pods dying with UNSUPP...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd Operator
Version: 4.5
Hardware: s390x
OS: Linux
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Sam Batschelet
QA Contact: Prashanth Sundararaman
URL:
Whiteboard:
Depends On:
Blocks: 1831664
TreeView+ depends on / blocked
 
Reported: 2020-04-19 19:24 UTC by Prashanth Sundararaman
Modified: 2021-05-14 14:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1831664 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:28:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 317 0 None closed Bug 1825667: pkg/cmd/render: add support for s390 and s390x arch 2020-09-01 07:26:16 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:28:54 UTC

Description Prashanth Sundararaman 2020-04-19 19:24:00 UTC
Description of problem:
Tried a 4.4 libvirt install of OCP on an s390x system. Noticed that two new pods - etcd-metrics and etcd-member on the bootstrap node was dying with:

"etcd on unsupported platform without ETCD_UNSUPPORTED_ARCH=s390x set"

On talking to the etcd-team it looks like the Cluster-Etcd-Operator needs to add this environment variable when rendering the yaml for these pods.

Version-Release number of selected component (if applicable):
4.4/4.5

How reproducible:
All the time

Steps to Reproduce:
OCP libvirt install on an s390x system. Do a "sudo crictl ps --all" on the
bootstrap node and "sudo crictl logs" on the etcd containers to notice the error.

Comment 4 ge liu 2020-05-08 03:35:30 UTC
@Prashanth Sundararaman, could u help to tried it again? We have not env to cover ocp test on platform: s390s, thanks in advance!

Comment 5 errata-xmlrpc 2020-07-13 17:28:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.