Bug 1825697 - Missing dependencies web-assets-httpd and js-jquery1 for zabbix40-web 4.0.17-1.el8
Summary: Missing dependencies web-assets-httpd and js-jquery1 for zabbix40-web 4.0.17...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: zabbix40
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-20 00:26 UTC by Dmitry Mikhailov
Modified: 2021-02-09 01:40 UTC (History)
2 users (show)

Fixed In Version: zabbix40-4.0.27-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-09 01:40:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Dmitry Mikhailov 2020-04-20 00:26:14 UTC
Description of problem:
I can't install zabbix40-web on CentOS 8.1 due to missing dependencies: web-assets-httpd and js-jquery1.

Version-Release number of selected component (if applicable):
4.0.17-1.el8

How reproducible:
Always

Steps to Reproduce:
1. Enable EPEL repo
2. dnf install zabbix40-web

Actual results:
zabbix40-web not installed, dnf output follows:
Error: 
 Problem 1: conflicting requests
  - nothing provides js-jquery1 needed by zabbix40-web-4.0.17-1.el8.noarch
  - nothing provides web-assets-httpd needed by zabbix40-web-4.0.17-1.el8.noarch
 Problem 2: package zabbix40-web-mysql-4.0.17-1.el8.noarch requires zabbix40-web = 4.0.17-1.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides js-jquery1 needed by zabbix40-web-4.0.17-1.el8.noarch
  - nothing provides web-assets-httpd needed by zabbix40-web-4.0.17-1.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Expected results:
zabbix40-web and it's dependencies successfully installed

Additional info:
One can overcome the problem by installing the CentOS 7 versions of the aforementioned software and their single dependency:
dnf install  https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/j/js-jquery1-1.12.4-2.el7.noarch.rpm https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/w/web-assets-httpd-5-1.el7.noarch.rpm  https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/w/web-assets-filesystem-5-1.el7.noarch.rpm

Therefore one just needs to rebuild the same RPM's for CentOS 8

Comment 1 Orion Poplawski 2020-12-13 22:41:58 UTC
Actually, I was moving to just bundling these.  And I might just retire this package from EPEL8 since it never was really right.

FYI - you might want to try installing Zabbix 5.0 from the module:

dnf module install zabbix/server

Comment 2 Fedora Update System 2021-01-24 23:14:05 UTC
FEDORA-EPEL-2021-ae79bd1daf has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-ae79bd1daf

Comment 3 Fedora Update System 2021-01-25 01:49:43 UTC
FEDORA-EPEL-2021-ae79bd1daf has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-ae79bd1daf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-02-09 01:40:39 UTC
FEDORA-EPEL-2021-ae79bd1daf has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.