Bug 1825709 - When silence an alert, can just input space in the "Comment" required field
Summary: When silence an alert, can just input space in the "Comment" required field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Andrew Pickering
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-20 02:13 UTC by hongyan li
Modified: 2020-07-13 17:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:28:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5109 0 None closed Bug 1825709: Monitoring: Don't allow silence comments to only contain whitespace 2020-06-23 10:06:28 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:28:54 UTC

Description hongyan li 2020-04-20 02:13:04 UTC
Description of problem:
When silence an alert, can just input space in the "Comment" required field

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-18-184707

How reproducible:
always

Steps to Reproduce:
1.Go to Monitoring-Alerting
2.Click combo icon to silence an Alert
3.Input space in the "Comment" required field, created the silence successfully

Actual results:
Input space in the "Comment" required field, created the silence successfully

Expected results:
Input space in the "Comment" required field, when click "slience" button, get prompt message

Additional info

Comment 4 hongyan li 2020-04-22 01:02:11 UTC
Test with payload 4.5.0-0.nightly-2020-04-21-103613
when silence alert, put space in the comments field, get message "Comment is required."

Comment 5 errata-xmlrpc 2020-07-13 17:28:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.