Bug 1825757 - Gather ConfigMaps from openshift-config namespace (backport to 4.4)
Summary: Gather ConfigMaps from openshift-config namespace (backport to 4.4)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Martin Kunc
QA Contact: Angelina Nikiforova
Radek Vokál
URL:
Whiteboard:
Depends On: 1825756
Blocks: 1825758 1825770
TreeView+ depends on / blocked
 
Reported: 2020-04-20 07:21 UTC by Martin Kunc
Modified: 2020-06-02 11:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Added collection of Configurations from ConfigMaps from openshift-config namespace Reason: We want to see if certificates are used for cluster CA and gather other cluster related settings from openshift-config namespace. Result:
Clone Of: 1825756
: 1825758 (view as bug list)
Environment:
Last Closed: 2020-06-02 11:17:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift insights-operator pull 96 None closed Bug 1825757: Collecting config maps 2020-07-27 13:45:42 UTC
Red Hat Product Errata RHBA-2020:2310 None None None 2020-06-02 11:18:29 UTC

Description Martin Kunc 2020-04-20 07:21:59 UTC
+++ This bug was initially created as a clone of Bug #1825756 +++

Description of problem:
Insights operator wasn't collecting cluster wide ConfigMaps from openshift-config. We should add them.

Version-Release number of selected component (if applicable):
4.2

How reproducible:


Steps to Reproduce:
1. Install OpenShift 4.2 with enabled Insights Operator
2. Wait until IO collects and sends the archive
3. Look into the archive

Actual results:
Archive is missing ConfigMaps from openshift-config

Expected results:
Archive has ConfigMaps from openshift-config

Additional info:

Comment 1 Ben Parees 2020-04-22 14:16:03 UTC
I don't see this as a 4.4.0GA blocker, moving to 4.4.z.

Comment 5 Angelina Nikiforova 2020-05-25 13:01:34 UTC
Fixed and verified in 4.4.0-0.nightly-2020-05-25-020741

Comment 7 errata-xmlrpc 2020-06-02 11:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310


Note You need to log in before you can comment on or make changes to this bug.