Bug 1825774 - Keep reporting `secret \"pull-secret\" not found` in the samples operator log
Summary: Keep reporting `secret \"pull-secret\" not found` in the samples operator log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-20 09:06 UTC by XiuJuan Wang
Modified: 2020-07-13 17:28 UTC (History)
0 users

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:28:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 264 0 None closed Bug 1825774: add back missing parts to make openshift-config namespace secret list… 2020-10-02 09:30:36 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:28:54 UTC

Description XiuJuan Wang 2020-04-20 09:06:15 UTC
Description of problem:
samples-registry-crendentials secret has been removed as expected, but samples operator still reports "metrics pull secret retrieval failed with: secret \"pull-secret\" not found" .

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-18-184707

How reproducible:
always

Steps to Reproduce:
1.Check samples operator logs
2.
3.

Actual results:
Keep reporting "metrics pull secret retrieval failed with: secret \"pull-secret\" not found"

Expected results:
Should not report this error

Additional info:

Comment 3 Gabe Montero 2020-04-22 13:06:34 UTC
this bug was introduced by the 4.5 change https://github.com/openshift/cluster-samples-operator/pull/249 where samples operator now takes advantage of internal image registry and associated imagestream related features introduced in 4.5 to use the install pull secret if it has credentials for the source image registry in question,
and with QE's quick discover was corrected before 4.5 shipped 

NO DOC UPDATE NEEDED

Comment 4 XiuJuan Wang 2020-04-24 03:29:38 UTC
Can't reproduce this bug in 4.5.0-0.nightly-2020-04-24-001451 cluster.

Comment 5 errata-xmlrpc 2020-07-13 17:28:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.