Bug 1825828 - align operator structure to be similar with other operators owned by the team
Summary: align operator structure to be similar with other operators owned by the team
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Maciej Szulik
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-20 10:47 UTC by Maciej Szulik
Modified: 2020-07-13 17:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:28:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-scheduler-operator pull 235 0 None closed Bug 1825828: Align naming and directory structure with other k8s operators 2020-09-24 14:26:41 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:28:54 UTC

Description Maciej Szulik 2020-04-20 10:47:17 UTC
It's easier to maintain operators if they follow the same structure.

Comment 3 RamaKasturi 2020-05-05 06:58:38 UTC
Suggestion to verify the bug was to run all the scheduler operator cases to make sure that there is no regression. Ran all the tests present in the file [1] and did not see any issues, so moving the bug to verified state.

[1] https://github.com/openshift/cucushift/blob/master/scheduler/operator.feature

Payload used to verify the bug :
================================
[ramakasturinarra@dhcp35-60 verification-tests]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-05-03-172622   True        False         23h     Cluster version is 4.5.0-0.nightly-2020-05-03-172622

Comment 4 errata-xmlrpc 2020-07-13 17:28:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.