Bug 1825866 - Namespace in the operator backed service url should be dynamic
Summary: Namespace in the operator backed service url should be dynamic
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Karthik Jeeyar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-20 12:20 UTC by Karthik Jeeyar
Modified: 2020-07-13 17:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: dynamic namespace params is missing in the operator backed service link from Add page Consequence: By clicking the operator backed service link, the namespace is not set to the active namespace. Fix: Add dynamic param in the OBS url Result: When OBS link is clicked, it is now redirected with the active namespace.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:29:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
Namespace in the operator backed service url should be dynamic (106.60 KB, image/png)
2020-06-10 22:53 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5106 0 None closed Bug 1825866: fix operator backed link in add page 2020-06-30 18:27:24 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:29:22 UTC

Description Karthik Jeeyar 2020-04-20 12:20:28 UTC
Description of problem:
Operator backed service link in the Add page should have dynamic namespace in the url.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

Steps to Reproduce:
1.Go to the Add page
2.click on the Operator backed service link

Actual results:
Namespace in the url is not set to the active namespace from the Add page

Expected results:
Namespace in the url should be the active namespace.

Comment 3 spathak@redhat.com 2020-06-10 22:53:34 UTC
Created attachment 1696592 [details]
Namespace in the operator backed service url should be dynamic

Comment 4 spathak@redhat.com 2020-06-10 22:54:31 UTC
Verified on build number: 4.5.0-0.ci-2020-06-07-034617
Verified on browser: Chrome 76

Comment 5 errata-xmlrpc 2020-07-13 17:29:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.